PDA

View Full Version : Error when installing Pentaho Metadata Editor?



quanta
05-06-2008, 06:41 AM
I have downloaded PME, and extract it to pentaho-demo folder.


ls
cwm docs jdbc lib libext libswt metaeditor.sh releasenotes.txt samples simple-jndi
After that, I run metaeditor.sh and get error:


$ ./metaeditor.sh
INFO 06-05 04:41:28,498 (VfsLog.java:info:122) -Using "/tmp/vfs_cache" as temporary files store.
Exception in thread "main" org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]
at org.eclipse.swt.SWT.error(Unknown Source)
at org.eclipse.swt.widgets.Display.createDisplay(Unknown Source)
at org.eclipse.swt.widgets.Display.create(Unknown Source)
at org.eclipse.swt.graphics.Device.<init>(Unknown Source)
at org.eclipse.swt.widgets.Display.<init>(Unknown Source)
at org.eclipse.swt.widgets.Display.<init>(Unknown Source)
at org.pentaho.pms.editor.MetaEditor.main(MetaEditor.java:3530)
This is java version which I am using:


$ java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) Server VM (build 10.0-b22, mixed mode)
Can anyone help me to install PME?

MattCasters
05-06-2008, 08:34 AM
On Linux/Unix, you need to have at least a graphical environment like X-Windows installed (X.org et all)

Matt