View Full Version : Load & Update metadata

06-21-2008, 03:31 AM

I've got questions about loading and updating metadata.

With the metadata editor, I created some metadata objects.
After copying to the solution directory, I was able to see it, when I clicked for a new ad-hoc report after login.

But, because I had a failure in the metadata, I wanted to correct. Therefore I replaced the metadata file in the solution directory, started the server and noticed, that the server ever was in last state.

It did not matter, if I deleted the metdata file, overwrote it and even after a restart of my whole system, it did not work.

A day later, the server had the new state.

So, is there a bug in the logic, which checks, if there are changes.

Seems to be a nice bug.



06-21-2008, 07:13 AM
Just an idea as I don't use metadata, did you try the refresh metadata option in the admin panel?


06-22-2008, 05:46 AM
Hi Tom,

yes I tried the following:

- refresh with the refresh function of the admin
- overwritting of the metadata file
- deleting of the metadata file
- change of the metadata file
- reboot of the whole system (Windows Vista Business Pro)

It always was the same effect, that the metadata were known to pentaho with the old state. The refresh definitely does not work in any way.

The only thing, I realized, what matters is the time frame of one day.

Because one day after the change of the metadata, pentaho recognizes the change and shows it.

Therefore, my thought was, that there is a bug in the logic, which checks for metadata change. But perhaps it is only a problem under
Vista (I don't know).



10-09-2008, 04:16 PM
I had the same exact problem you were having, and I think I may have figured out what was causing it.

I am using a DB based repository, so I would update my metadata info and still not see any changes. After updating my solution repository and then refreshing the metadata it started working.

My guess is that it stores the metadata files in the hibernate database, so you need to update the solutions it will slurp up the updated file, and then when you refresh the metadata gets the files from hibernate. *shrugs* Just a hunch.

I hope this works for you!

- Dan

02-03-2009, 08:49 AM
ThinkingPhoneNetworks has found the answer. I did have a similar problem: The newly published metadata wasn't visible. However, as I have just changed from file- to db-based, my second guess was to refresh the solution repository and then refresh the metadata. I worked flawlessly. []s, Fabio.

02-26-2009, 02:35 PM
I am completely frustrated by this. I switched to a MySQL-based repository, but still no go. I click on Refresh Repository and Refresh Metadata but I cannot get the metadata to change. If anyone really feels that they have a solution to this, can you go through all the steps that you use, starting from the metadata editor, how do you transfer/publish the XMI, restart the server? restart the browser?

I created CWM in MySQL, and tables appeared, but I am not convinced yet that my metadata is getting into there.

02-26-2009, 02:59 PM
I am less frustrated now, I found thread http://forums.pentaho.org/showthread.php?t=65655 and it seems that refresh in the Admin Console is a red herring, at least for 2.0 and that Tools>Refresh>Metadata in the browser is much more useful (wait for the OK to come back). It also seems to help to dismiss the panel showing the metadata, and then letting it reload.

02-26-2009, 04:09 PM
Tools>Refresh>Repository Cache also seems to help, I am not sure if it should be first or after Refresh>Metadata.

02-26-2009, 04:31 PM
Tools>Refresh>Repository Cache seems to work best when done before Tools>Refresh>Metadata. Wait for the response from Refresh>Metadata.