PDA

View Full Version : Problemas con formato de numeros decimales



Alex Aldrete
02-19-2009, 02:39 PM
Saludos comunidad pentaho en español.

Quisiera saber si algien tiene el mismo problema que yo y como lo puedo solucionar.

Lo que pasa es que estoy trabajando bajo Linux redhat, penthao 1.6GA y uso report designer para crear reportes.
mi problema es que al campo numerico le doi un formato #,##0.### para que me arroje un numero como este:

1,234,543.99

pero no lo hace, lo que me arroja es esto:

1.234.543,99

Eso no me sirve ya que estoy en Mexico y el separador decimal deve ser el punto.
mi bd esta en postgres encoding UTF-8. Esto se lo he cambiado a latin1 pero no funciono, si algien tiene una solicion, se lo agradecere, tal vez no cambie bien el encoding o sea cosa de Firefox, o que se yo. Gracias.

tdidomenico
02-19-2009, 02:52 PM
Estás utilizando una versión muy vieja, y lamentablemente no puedo hacer pruebas. Sí tengo en funcionamiento la 1.7 y la 2.0.

Desde el lado teórico, el tema de la localización siempre es algo complicado. Lo primero que deberías hacer es comprobar qué "locale" está utilizando tu servidor RedHat, ya que es posible que la máquina virtual Java tome la localización de ahí y la imponga al motor de reportes.

¡Saludos!

tdidomenico
02-19-2009, 03:58 PM
Alex, te pediría que no hagas "cross posting" entre foros (http://forums.pentaho.org/showthread.php?t=68013), ya que eso causa que luego probablemente una de las entradas quede vacía.

¡Gracias!

Alex Aldrete
02-19-2009, 06:35 PM
mil disculpas por lo de el foro, pero crei que asi tendria mas respuestas....:$

Por favor si tienen mas ideas, posteeenlas.