PDA

View Full Version : Losing KnowledgeFlow Component details



greg.soulsby
05-16-2009, 04:35 AM
When editing KnowdgeFlow components it repeatedly loses my values :eek:

For example,


I go into Configure for a Remove component and then cancel the change it reverts to an attribute.Add.
If I open a attribute.AddClasification which was saved as a J48 tree then the Classifier Choose is showing ZeroR rather than the J48 is was saved with

Thanks in advance.

Details of environment include


Using XML KnowlegdeFlow files
Ubunto 8.10, with all updates applied
2 gig memory
Terminal output follows

used CLASSPATH: :/usr/share/java/:/home/ibd/programmes/weka_3.6/weka-3-6-0//mysql-connector-java-5.0.5-bin.jar:/home/ibd/programmes/weka_3.6/weka-3-6-0//weka.jar
[KnowledgeFlow] Loading properties and plugins...
[KnowledgeFlow] Initializing KF...
Trying to add JDBC driver: RmiJdbc.RJDriver - Error, not in CLASSPATH?
Trying to add JDBC driver: jdbc.idbDriver - Error, not in CLASSPATH?
Trying to add JDBC driver: org.gjt.mm.mysql.Driver - Error, not in CLASSPATH?
Trying to add JDBC driver: com.mckoi.JDBCDriver - Error, not in CLASSPATH?
Trying to add JDBC driver: org.hsqldb.jdbcDriver - Error, not in CLASSPATH?
[Loader] Notifying listeners of instance structure avail.
---Registering Weka Editors---
[Loader] Notifying listeners of instance structure avail.
WARNING: unknown property 'visual.iconPath'!
WARNING: unknown property 'visual.animatedIconPath'!
WARNING: unknown property 'visual.iconPath'!
WARNING: unknown property 'visual.animatedIconPath'!
WARNING: unknown property 'visual.iconPath'!
WARNING: unknown property 'visual.animatedIconPath'!
WARNING: unknown property 'visual.iconPath'!
WARNING: unknown property 'visual.animatedIconPath'!
WARNING: unknown property 'visual.iconPath'!
WARNING: unknown property 'visual.animatedIconPath'!

Mark
05-16-2009, 04:54 AM
Hi Greg,

Thanks for the bug report. The configuration dialog for filters needs to be made consistent with those for classifiers, clusterers and association rules.

I can't replicate your problem AddClassification + J48 (under Mac OS X at least). Saving to XML and reloading still shows J48 as the selected classifier for me. I'll check it under Ubuntu next week. Can you send me your XML flow file for this example?

Cheers,
Mark.

greg.soulsby
05-16-2009, 08:16 AM
To clarify, the lose of details of, for example, the tree classifier, is not on save and then open but on opening the control and canceling - it reverts to something else in the Flow at that point.

BTY I have moved across to Windows and am getting similar problems.

greg.soulsby
05-16-2009, 09:05 AM
The configuration dialog for filters needs to be made consistent with those for classifiers, clusterers and association rules.


Does that mean there is a fix? What do I do to get my hands on it?

Mark
05-17-2009, 02:01 AM
I've made the customizer dialogs for classifiers, clusterers, filters and association rules consistent - each has an "OK" and "Cancel" button that operate as expected. These changes have been checked in to the stable-3-6 branch and trunk in subversion. They will also be available in the nightly snapshots of Weka from tonight:

http://www.cs.waikato.ac.nz/ml/weka/snapshots/

Cheers,
Mark.