PDA

View Full Version : nuevamente dashboards, error en linea



ajuarez
05-25-2009, 07:48 PM
Hola a todos, he revisado las lineas de mi xaction y vi que el error esta en la linea

<component-name>com.google.code.pentahoflashcharts.OpenFlashChartComponent</component-name>y me marca el siguiente error:
[es_161] Error: RuntimeContext.ERROR_0006 - [es_2] Action components do not validate: series_1.xaction (org.pentaho.platform.engine.services.runtime.RuntimeContext)

y si yo cambio el nombre de componente a
<component-name>UtilityComponent</component-name> me marca la siguiente leyenda, Action Successful, leyendo un poco más encontré que tenia que modificar el archivo systemListener.xml agregando la siguiente linea
<bean id="OpenFlashChartSystemListener" class="com.google.code.pentahoflashcharts.OpenFlashChartSystemListener">, lo cual me parecio lógico, pero cuando la agrego a mi archivo, mi bi_server no levanta... alguna sugerencia??

Nuevamente Gracias:D

Alex Aldrete
05-26-2009, 07:48 PM
Me puedes pasar la linea del catalina.out cuando tu BI server no levanta?

ajuarez
05-28-2009, 11:40 AM
Hola Alex, donde consigo el dato de catalina.out??

Saludos

Alex Aldrete
05-28-2009, 08:05 PM
Pues es el nombre del log que trae la vercion 2 estable del pentaho, esta en el directorio BI-Server

tdidomenico
05-29-2009, 10:52 AM
Fijate en <bi-server>/tomcat/bin/pentaho.log.

¡Saludos!

Alex Aldrete
05-29-2009, 01:37 PM
Gracias tdidomenico, no recorde que mi configuracion la movi para que el log me apareciera en la raiz del BI server, la ruta por default no la tome en cuenta...

Mil gracias por correjir el error.




Namarie

ajuarez
05-29-2009, 02:07 PM
ok gracias, la verdad es un listado enorme en el archivo, asi que se los adjunto como pdf

Nuevamente gracias

ajuarez
05-29-2009, 02:14 PM
:p, sorry, leí lo que arrojo el log y corregí lo del systemListener.xml y ya levanto correctamente el tomcat, ya solo me quedan los errores de los dashboards, así que la solución de agregar ese bean extra tampoco funciono.

snif snif :(

Este es el error que me arroja:

[es_161] Error: RuntimeContext.ERROR_0012 - [es_33] ActionDefinition for com.google.code.pentahoflashcharts.OpenFlashChartComponent did not execute successfully (org.pentaho.platform.engine.services.runtime.RuntimeContext)[es_116] Debug: [es_21] Starting execute of workspace/Example/example.xaction (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_30] Getting runtime context and data (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_33] Loading action sequence definition file (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_34] audit: instanceId=5b1b6047-4c7c-11de-b415-d18c8e2b43d3, objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.platform.engine.services.runtime.RuntimeContext)
[es_14] Error: Base.ERROR_0002 - Ejecución fallida del Componente - java.lang.NoSuchMethodError: org.pentaho.platform.engine.core.system.PentahoSystem.getSolutionRepository(Lorg/pentaho/platform/api/engine/IPentahoSession;)Lorg/pentaho/platform/api/repository/ISolutionRepository; (com.google.code.pentahoflashcharts.OpenFlashChartComponent)
[es_161] Error: RuntimeContext.ERROR_0012 - [es_33] ActionDefinition for com.google.code.pentahoflashcharts.OpenFlashChartComponent did not execute successfully (org.pentaho.platform.engine.services.runtime.RuntimeContext)
[es_161] Error: SolutionEngine.ERROR_0007 - [es_27] Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)

Server Version: Pentaho Platform Engine Core 3.0.0.M1.36789


Agrego el archivo log por si ayuda en algo

Gracias

jorge_perez_a
05-20-2010, 05:05 PM
Tengo el mismo problema.......
no puedo configurar...el openflash me da un error 00012---

UTILIZO LA Version 3.5.0
el jfreechar todo correcto-----
el problema solo me da con las graficas flash..
utilizo sistema OPERATIVO
RED HAT 5.5 TIKANGA
supuestammente dice que falta este componente
com.google.code.pentahoflashcharts.OpenFlashChartSystemListener

coloco esta linea en el archivo systemListeners.xml

q esta en la ruta:::.

/srv/pentaho/biserver-ce/pentaho-solutions/system
pero al reiniciar el servicio el servidor no arranca...........
por favor ayudenme necesito trabajar con cdf de pentaho utilizando openflash.......

GRACIAS .
JORGE PEREZ..