PDA

View Full Version : Seeking help in Adhoc Reports



herwinrayen
07-14-2009, 08:37 AM
Hi ,

Greetings to you.I am a beginner to Pentaho and my requirement is to create Adhoc report.So I have downloaded MetaEditor latest version and I run the metadata-editor.bat from command prompt.While execution I faced below error.,

The input line is too long..

So I have copied all the *.jar file from the metadata-editor solution and pasted in "..\Java\jdk1.6.0\lib" and "..\Java\jdk1.6.0\jre\lib\ext" . Then I run the command "C:\Herwin\metadata-editor>java org.pentaho.pms.ui.MetaEditor" from command prompt.On execution below exception is thrown in command prompt.

C:\Herwin\metadata-editor>java org.pentaho.pms.ui.MetaEditor
INFO 14-07 12:42:18,843 - Using "C:\DOCUME~1\herwin\LOCALS~1\Temp\vfs_cache" a
temporary files store.
Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3346 or s
t-gtk in swt.library.path, java.library.path or the jar file
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
at org.pentaho.pms.ui.MetaEditor.main(MetaEditor.java:3545)

Hope your help will be great to solve this issue.I will wait for your response.

wgorman
07-22-2009, 09:43 AM
You posted an identical thread here:
http://forums.pentaho.org/showthread.php?p=218263#post218263

Please avoid posting the same question multiple times. Thanks!

Will