PDA

View Full Version : Fuentes perdidas en rtf



Ayak
07-22-2009, 06:14 AM
Buenas a todos/todas,

Estoy tratando de crear cartas donde varían algunos parámetros (usuario, códigos...), tengo varios problemas, está claro que para textos largos o cartas complejas, el pentaho no está pensado, pero el principal problema es que no consigo que al crear el informe en rtf me conserve las fuentes originales.

He intentado activando la opción fonts embedded, pero nada, me cambia todas las fuentes a Helvetica (conserva tamaño), independientemente de que en el origen esté en Garamond, Arial o lo que le eche. Esto me descuadra todos los campos, por lo que me desaparece texto, o se me monta con otro o simplemente el rtf crea unas tablas imposibles de editar.

¿alguna sugerencia? Gracias, mañana, mucho más. :D

tdidomenico
07-24-2009, 09:28 AM
Aparentemente no todas las fuentes pueden ser embebidas: http://wiki.pentaho.com/display/Reporting/5.+Graphical+Report+Elements. Utilizando PRD 2.0 y la plataforma 3.0 para generar los reportes en Windows y abriendo el RTF con Abiword en un Linux recién instalado, pude lograr embeber y ver luego correctamente las fuentes "Palatino" y "Calibri". Probé especialmente con estas porque son fuentes dentro de todo "normales".

Te recomendaría probar por lo tanto con alguna fuente de este tipo primero, para confirmar que funciona el embebido, y luego ver con qué fuentes podés aplicarlo.

¡Saludos!

Ayak
08-14-2009, 01:57 AM
Gracias por la respuesta, la solución al final fue instalar las fuentes en el servidor, pues este basado en Red Hat no tenía las fuentes que necesitaba.

S!