PDA

View Full Version : No muestra reportes me marca error



shobbie
07-31-2009, 04:25 PM
Que tal compañeros, estoy usando un el servidor de pentaho la version 3 , y para haecr mis reportes utilizo la version de report designer 2, mi problema es que cuando publico mis reportes en el server y los intento ejecutar no me los habre y me marca estas lineas de error

[es_161] Error: null (org.pentaho.platform.plugin.action.jfreereport.JFreeReportComponent)[es_116] Debug: [es_21] Starting execute of GEQ//Reporte Apoyo a la Economia Familiar.xaction (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_30] Getting runtime context and data (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_33] Loading action sequence definition file (org.pentaho.platform.engine.services.solution.SolutionEngine)
[es_116] Debug: [es_34] audit: instanceId=86152289-7e0d-11de-a81e-7fc1e0881dae, objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.platform.engine.services.runtime.RuntimeContext)
[es_14] Error: JFreeReport.ERROR_0007 - [es_185] Could not parse report GEQ/Reporte Apoyo a la Economia Familiar.xml - java.lang.NullPointerException (org.pentaho.platform.plugin.action.jfreereport.JFreeReportComponent)
[es_161] Error: null (org.pentaho.platform.plugin.action.jfreereport.JFreeReportComponent)
[es_161] Error: RuntimeContext.ERROR_0012 - [es_33] ActionDefinition for JFreeReportComponent did not execute successfully (org.pentaho.platform.engine.services.runtime.RuntimeContext)
[es_161] Error: SolutionEngine.ERROR_0007 - [es_27] Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)

Server Version: Pentaho Platform Engine Core 3.0.0-STABLE.37736


No se si me falte agregar algo al server o algun servicio que requiera para poder ver mis reportes, ya que ningun reporte me lo muestra, en este reporte estoy utilizando subreportes nada de parametros, si alguien me puede ayudar se lo agradeceria

Saludos.......

tdidomenico
08-03-2009, 10:46 AM
NullPointerException indica que el motor está teniendo problemas para encontrar algún recurso requerido. Podría ser que no hayas definido en el servidor la conexión a BD que utilizaste en el Report Designer, ó problemas por utilizar espacios ó caracteres especiales (áéíóúñç...) en los nombres de archivos.

¡Saludos!