PDA

View Full Version : I can't publish my Business Model to server for Adhoc Reporting



EkGia
09-10-2009, 08:46 AM
Hi
i create a new Business Model with Metadata Editor.

But if I want publish this to server I have the error:
Action Failed
Unable to save file (metadata.xmi) to server. Correct any server, id or password errors and try again

Publish location: samples
URL: localhost:18080/pentaho/RepositoryFilePublisher
(my BI Server port is 18080 and not 8080)
publish password and user id are correct

i have no problems to publish a report to server

wgorman
09-11-2009, 12:46 AM
Do you have a defined samples solution? Try publishing it to steel-wheels instead, or into another solution folder you've already defined.

muralidrans
10-09-2009, 06:59 AM
:)Hi,

I have created a model using Pentaho meta-editor and published in server.
if u gonna publish a model in server, say u gonna create a new model and going to test with in steel-wheels,

File --> publish to server , asks
Publish Location --> steel-wheels
web Publish URL --> Let it be default
publish password --> passwordxyz , (this should be set by u in \pentaho-solutions\system\publisher_config.xml)
Server User-id --> joe
Server password --> password

--> Server should be in start mode to communicate meta-editor with server.. and it prompts u to overwrite the existing metadata.xmi model in steel-wheels...u jus overwrite the model and proceed with steel-wheels or u can creat a new test solution and u can define the publish location to test-solution....

Thnx
Murali

naveen.arumugam
11-06-2009, 01:39 AM
Hi

I am using 3.5 stable PME.

While publishing I get "Unable to save file (metadata.xmi) to server. Correct any server, id or password errors and try again"

So, I created a folder 'samples' under 'pentaho-solution' and dropped metadata.xmi into that location. When I refreshed the 'Reporting Metadata' I get the message '1 solution reloaded'.

But, nothing happens.

I want help. where to drop the '.xmi' file which folder ...under which folder... server to be stopped/restarted ..and further actions required... etc. It'll help.

thx
naveen

naveen.arumugam
11-09-2009, 03:26 PM
Hi

After saving my file under pentaho-solutions/samples directory, and after refreshing, I was able to see the model, but the fact tables are missing.

Meanwhile, today, when I tried to publish I get the same error "Unable to save file (metadata.xmi) to server. Correct any server, id, or password errors and try again."

Thanks
Naveen