PDA

View Full Version : Deploy Pat-0.6-SNAPSHOT.war



Gius
03-05-2010, 08:12 AM
Dear all,
I'm trying to deploy Pat-0.6-SNAPSHOT.war in Tomcat.
Can I add sql server driver to the list of driver that appears when I click on the connection button? I have my own database in Sql Server.
Thanks for your reply.
Giuseppe

bugg_tb
03-05-2010, 08:25 AM
If I'm not mistaken you put the driver in webapp/pat.../WEB-INF/lib and restart.

We've not really tested on MSSQL so let us know if you have any issues.

Thanks for trying.

Tom

pstoellberger
03-05-2010, 08:40 AM
yeah web-inf/lib is the correct path

when you run it in java 6 it just has to be somewhere on the classpath if i'm not mistaken

-paul

Gius
03-05-2010, 09:30 AM
Thank you for your quick reply Tom and Paul.
Unfortunately, if I simple put the jar under the directory web-inf/lib and restart tomcat, nothing change, in fact in the list appear the driver already loaded.
Giuseppe

bugg_tb
03-05-2010, 10:34 AM
That list is dynamic and should adjust depending on which jar's it finds, if its not automatically added to the list, it will be something we need to look at

Gius
03-05-2010, 01:07 PM
Hi guys,
I did some test. If I delete the jar related to Mysql (mysql-connector-java-5.1.6.jar) in the list box mysql disappear. But if I add something unknown like sqljdbc4.jar for Sql Server nothing happens. The drivers are mapped somewhere? Thanks a lot
Giuseppe

pstoellberger
03-16-2010, 10:32 AM
no the drivers are not mapped
but our JDBC driver finder scans the libs for classes that can be recognized as java.sql.Driver classes.

we never had any problems with that

are you running tomcat with Java 1.6? I just read that sqljdbc4.jar needs Java 1.6

p.s: sorry for the late reply

sramazzina
03-16-2010, 11:34 AM
Gius,

could the jar file be corrupted? If so it cannot be accessed by the finder process and the driver isn't recognized. Try to open it manually just to verify everything is ok ...

Hope this helps.
S.

Gius
04-12-2010, 03:50 AM
The problem is the driver...probably I have both sqljdbc4.jar and sqljdbc.jar,maybe they are in conflict...When I use only the sqljdbc.jar everything is ok... Thanks a lot,
Giuseppe

wselwood
04-12-2010, 06:33 AM
Hi Giuseppe

Yeah I have seen that before. If you have both drivers in the class path they conflict. No idea why, just removed one to make it work. Seems to be a problem with the jvm or drivers (more likely the drivers) Just make sure you only have one of the jars and every thing is usually fine.

Good luck

Wil