PDA

View Full Version : Problemas al iniciar el pentaho con el start_hypersonic.bat



alveol85
04-26-2010, 04:18 PM
Hola

Tengo un problema cuando inicio el pentaho ejecutándolo mediante una tarea programada de windows server 2008, también me sucede ejecutándolo desde código c# con el commando process.start(); y ejecutandolo desde un registro, me sale un mensaje diciendo: "windows no puede encontrar el archivo 'start_hypersonic.bat' asegurese de que la ruta y el nombre de archivo estan escritos correctamente y vuelva a intentarlo."
pero en el momento de ejecutar el archivo start-pentaho.bat dándole doble click sube normalmente.
alguien sabe por que puede suceder esto.
mi sistema operativo es win xp y utilizo la version del pentaho 3.0 estable

muchas gracias por la atencion prestada.

tdidomenico
04-29-2010, 10:19 AM
Asumo que estás arrancando con "start-pentaho.bat". Fijate que dentro de ese archivo hay cambios de directorio relativos. En el caso de Hypersonic, es "cd data". Esto asume que estás parado en el directorio "biserver-ce". Si estás ejecutando "start-pentaho.bat" desde otro lugar, ese cd no va a funcionar y no vas a encontrar "start-hypersonic.bat" dentro del directorio resultante.

Dos posibilidades simples: arrancar Hypersonic con otra tarea del task manager, ó editar start-pentaho.bat y ponerle rutas absolutas.

¡Saludos!

alveol85
05-05-2010, 07:06 PM
Hola tdidomenico muchas gracias por responderme
acabo de solucionar el problema, he creado un nuevo .bat en el cual especifico la ruta en donde esta el archivo start-pentaho.bat, le he especificado la ruta del archivo start-hypersonic que se encuentra en la carpeta data indicada en el propio archivo start-pentaho.bat pero aun me sacaba el mismo mensaje de "windows no puede encontrar el archivo 'start_hypersonic.bat' asegurese de que la ruta y el nombre de archivo estan escritos correctamente y vuelva a intentarlo."

Pero si alguien tiene este problema intenten de esta forma

muchas gracias por la atencion prestada.