PDA

View Full Version : How do I run the BI server compiled from source?



rtrajano
05-13-2010, 10:14 AM
I've checked out all the bi-platform-v2 trunk code from the svn repo and got it to compile without errors in Eclipse under Linux by following the wiki guide (http://wiki.pentaho.com/display/ServerDoc2x/Building+and+Debugging+Pentaho+with+Eclipse). How do I package it up to make something similar to the pentaho biserver-ce where I can start the server, login via web browser, and display/create reports?

Thanks!

mlowery
05-17-2010, 03:08 PM
ant -f bi-platform-assembly/assembly.xml clean-all resolve assemble package

rtrajano
05-26-2010, 09:08 AM
I'll put my steps here for future reference. Thanks mlowery






I'm building Pentaho CE 3.5.2 Stable under Linux from the command line. I tested this with Ubuntu 10.4 and Fedora 10. The hyperlinks might be shortened so make sure its the whole URL if you are copying and pasting.
Install subversion & ant (yum or apt-get)
Download apache tomcat 5.5.26
wget http://archive.apache.org/dist/tomcat/tomcat-5/v5.5.26/bin/apache-tomcat-5.5.26.tar.gz (http://archive.apache.org/dist/tomcat/tomcat-5/v5.5.26/bin/apache-tomcat-5.5.26.tar.gz)
as root untar apache-tomcat into /build/assemblyCache/
sudo mkdir -p /build/assemblyCache && tar -xvvzf apache-tomcat-5.5.26.tar.gz -C /build/assemblyCache/
change ownership of the /build/assemblyCache directory to the user you are compiling as
sudo chown -R user:user /build/assemblyCache/
checkout the code
svn co http://source.pentaho.org/svnroot/bi-platform-v2/tags/3.5.2.stable
When it's done downloading enter the source code directory
cd 3.5.2.stable
Start the build
ant -f bi-platform-assembly/assembly.xml clean-all resolve assemble package-targz
Go to this directory for the tar file
cd bi-platform-assembly/dist/
(OPTIONAL) Untar this somewhere, export your JAVA_HOME environment variable, run "biserver-ce/start-pentaho.sh", and visit http://localhost:8080 in your web browser.

bugg_tb
05-26-2010, 09:13 AM
You could always just use the community build framework
http://wiki.pentaho.com/display/COM/CBF2.0

:)

rtrajano
05-26-2010, 10:07 AM
Thanks, I think I found that page before but it seemed a little outdated. The ant script is no longer available under download and it's building 1.7, but i'll look over it again as it does contain some good info.

bugg_tb
05-26-2010, 10:18 AM
erm its not outdated its pretty much the defacto standard for building from source in a sensible manner, if you dont' work in the white towers, but the wiki has blown up, I'll see what happened to the ant file.

bugg_tb
05-26-2010, 10:19 AM
http://wiki.pentaho.com/display/COM/CBF2.1

Wrong link ;)

Sorry bout that.

Tom

rtrajano
07-12-2010, 01:59 PM
Thanks Tom, I ended up using the 3.5 version of the CBF located here:

http://wiki.pentaho.com/display/COM/CBF+-+Community+Build+Framework

I have another question now that I have it built and running using the CBF. Is it possible to build Pentaho without an active connection to the internet? IVY complains if it can't resolve dependencies and the build fails if started offline. I found this wiki article (http://wiki.pentaho.com/display/PEOpen/Build+Architecture) that talks about the build architecture but whoever wrote it never finished adding the part about offline builds. He just put a place marker that says:

"**** INSERT INFO HERE ABOUT RUNNING THE BUILD OFFLINE ****"

Taqua
07-12-2010, 02:58 PM
Ivy caches all libraries it fetches from the net. So after a successful "resolve" of all packages you should be fine for running offline. The next resolve will use the jars from the cache. However, each resolve can still go out and looks whether there are new files.

To make it a forced offline mode, remove the lines mentioning the "main-chain" and "default-chain" from your ivysettings.xml files and also remove the pentaho-resolve that is defined there. This way Ivy wont try to reach the its default maven repositories and will only rely on the local cache.

Be aware that if your cache is lost or incomplete, this strategy will end in resolve errors and tears.

rtrajano
07-20-2010, 11:43 AM
Removing those entries from all the ivysettings.xml files still caused it to look online for dependencies. I ended up greping for all the dependencies in all the ivy.xml files, extracting the org/mod/rev of each dependency, and using the ivy:install task to copy the dependency to an offline filesystem repo I added to all my ivysettings.xml

I added all these entries into a new target in the ant build files. I read up on this task here (http://ant.apache.org/ivy/history/2.0.0-alpha2/use/install.html) and the tutorial for building an offline repo (http://ant.apache.org/ivy/history/2.0.0-alpha2/tutorial/build-repository.html) helped also.

<ivy:install overwrite="true" transitive="false" organization="EXTRACTED ORG" module="EXTRACTED MOD" revision="EXTRACTED REV" from="shared" to="offline-repo" />

Now it's able to compile and build without an active internet connection, not that I don't like how the build process works, but I ran into a problem where 3.5.2 stable no long builds due to the maven2 repos updating a dependency that pentaho requires a certain version.

sagarkohli01
07-22-2010, 05:34 AM
@rtrajano

completely agree with, currently i am also facing compilation issue for the same code which i have compiled successfully before. currently it is getting following issue

ine#pentaho-reporting-engine-classic-extensions;3.6-SNAPSHOT] in [default]
---------------------------------------------------------------------
| | modules || artifacts |
| conf | number| search|dwnlded|evicted|| number|dwnlded|
---------------------------------------------------------------------
| default | 232 | 64 | 12 | 44 || 180 | 5 |
---------------------------------------------------------------------
[ivy:resolve]
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: UNRESOLVED DEPENDENCIES ::
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: pentaho-library#libbase;1.1-SNAPSHOT: configuration not found in pentaho-library#libbase;1.1-SNAPSHOT: 'default_external'. It was required from pentaho-reporting-engine#pentaho-reporting-engine-classic-core;3.6-SNAPSHOT default
[ivy:resolve] :: pentaho-library#libloader;1.1-SNAPSHOT: configuration not found in pentaho-library#libloader;1.1-SNAPSHOT: 'default_external'. It was required from pentaho-library#libdocbundle;1.1-SNAPSHOT default
[ivy:resolve] :: pentaho-library#libpixie;1.1-SNAPSHOT: configuration not found in pentaho-library#libpixie;1.1-SNAPSHOT: 'default_external'. It was required from pentaho-library#libloader;1.1-SNAPSHOT default
[ivy:resolve] :: pentaho-library#libxml;1.1-SNAPSHOT: configuration not found in pentaho-library#libxml;1.1-SNAPSHOT: 'default_external'. It was required from pentaho-library#libdocbundle;1.1-SNAPSHOT default
[ivy:resolve] :: pentaho-library#libfonts;1.1-SNAPSHOT: configuration not found in pentaho-library#libfonts;1.1-SNAPSHOT: 'default_external'. It was required from pentaho-reporting-engine#pentaho-reporting-engine-classic-core;3.6-SNAPSHOT default
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS



any IDea about this:confused:

rtrajano
07-22-2010, 08:55 AM
If you are building from the commandline add the -v parameter to ant so you get the verbose message logs and paste those if your still having problems. What version of the bi-server are you compiling? It seems like its not getting the dependencies located on the artifactory repo that pentaho hosts at http://repo.pentaho.org/artifactory/repo/

you can't browse it without a login so its hard to tell if that dependency revision is still being hosted there. For example the libpixie i needed to build 4.0.0-GA of the bi-server is revision 1.1.6 and its metadata is located here
http://repo.pentaho.org/artifactory/repo/pentaho-library/libpixie/1.1.6/libpixie-1.1.6.ivy.xml

In your ivysettings.xml files there is a resolver called shared-ivy which points to the pentaho repo. The ivy pattern="http://repo.pentaho.... is filled in by the ivy.xml dependency tags. The couple of failed dependencies are all sub dependencies that stem from the reporting-engine.