PDA

View Full Version : PDI client spoon.sh crashes on CDH3



Jasper
11-24-2010, 03:54 PM
In an effort to bypass the problems I have here:

http://forums.pentaho.com/showthread.php?79189-Linking-up-PDI-to-Hadoop (http://forums.pentaho.com/showthread.php?79189-Linking-up-PDI-to-Hadoop&goto=newpost)

I now tried to install the pdi client (from pdi-ee-client-4.1.0-GA.tar.gz) directly on the CDH3.

But after unpacking, installing the licenses and starting spoon.sh I get the welcome screen and soon afterwards it crashes.

Saying:

=========================================

training@training-vm:~/data-integration$ ./spoon.sh
/home/training/data-integration
/home/training/data-integration
DEBUG: Using JAVA_HOME
DEBUG: _PENTAHO_JAVA_HOME=/usr/lib/jvm/java-6-sun
DEBUG: _PENTAHO_JAVA=/usr/lib/jvm/java-6-sun/bin/java
DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=
INFO 24-11 11:33:24,557 - Using "/tmp/vfs_cache" as temporary files store.
INFO 24-11 11:33:35,441 - Spoon - Logging goes to file:///tmp/spoon_baa3d99e-f801-11df-b54c-bd44d9109027.log
INFO 24-11 11:33:40,049 - Refreshing org.springframework.context.support.ClassPathXmlApplicationContext@75ace1: display name [org.springframework.context.support.ClassPathXmlApplicationContext@75ace1]; startup date [Wed Nov 24 11:33:40 PST 2010]; root of context hierarchy
INFO 24-11 11:33:40,360 - Loading XML bean definitions from class path resource [spring.xml]
INFO 24-11 11:33:40,988 - Bean factory for application context [org.springframework.context.support.ClassPathXmlApplicationContext@75ace1]: org.springframework.beans.factory.support.DefaultListableBeanFactory@13f85de
INFO 24-11 11:33:41,224 - Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@13f85de: defining beans [org.springframework.context.annotation.internalCommonAnnotationProcessor,org.springframework.context.annotation.internalAutowiredAnnotationProcessor,org.springframework.context.annotation.internalRequiredAnnotationProcessor,xulLoader,org.pentaho.ui.xul.swt.SwtBindingFactory#0,xulInitController,schedulerDialogController,org.pentaho.di.spoon.scheduler.controllers.RecurrenceController#0,org.pentaho.di.spoon.scheduler.controllers.ErrorDialogController#0,org.pentaho.di.spoon.scheduler.controllers.SchedulerPerspectiveController#0,schedulerPerspective,org.pentaho.di.spoon.scheduler.ws.SchedulerServiceFactory#0,schedulerService]; root of factory hierarchy
WARN 24-11 11:33:43,132 - could not parse [vertical] as Align value
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb77ee9e0, pid=6726, tid=3067669392
#
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Client VM (16.3-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libpthread.so.0+0x79e0] pthread_mutex_lock+0x20
#
# An error report file with more information is saved as:
# /home/training/data-integration/hs_err_pid6726.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted
training@training-vm:~/data-integration$

=================================================


I also tried the binary Linux installer but I get the exactly the same error.

Any ideas?
(this is not going my way :-( )

jsanta
12-01-2010, 04:07 PM
I recently had the same problem trying to run a just decompressed Kettle 4.1 stable.
Fixed it (or just could run Spoon) by editing the spoon.sh file and adding these lines:


export AWT_TOOLKIT=
export XLIB_SKIP_ARGB_VISUALS=1


after the first line that looks like:

#!/bin/sh

It worked for me. Best regards,
José Ignacio

Jasper
12-01-2010, 07:13 PM
Didn't work for me ;-(

Is this right "export AWT_TOOLKIT=" ?

Shouldn't there be some value which it is set to ?

Jasper
12-01-2010, 07:33 PM
I got it to work another way! I changed the line from spoon.sh

MOZILLA_FIVE_HOME=$(find /usr/lib -maxdepth 1 -name xulrunner-[0-9]* | head -1)

into

MOZILLA_FIVE_HOME=$(find /usr/lib -maxdepth 1 -name xulrunner-1.9.1.[0-9]* | head -1)

because there was a newer version on my machine. I not 100% sure if this is because I downloaded some extra apps or it comes standard with CDH3.

jsanta
12-02-2010, 06:59 PM
Good you found a solution. It probably was because of some xulrunner/firefox or other update, I had a similar problem but with another app.
Just for the record, the export line is correct, setting the value to empty disables a Compiz workaround so some Java apps can run without problems (others, such as Spoon, Squirrel SQL, Netbeans, Eclipse, and Vuze have problems anyway...)

trastaf
02-20-2012, 04:15 PM
Hi, Maybe it's too late but I found a way to solve your problem

I edited the spoon.sh, you have to uncomment the following lines:
set MOZILLA_FIVE_HOME=/usr/lib/mozilla (this is the directory where mozilla installed)
set LD_LIBRARY_PATH=/usr/lib/mozilla

Then you need to comment those lines:

MOZILLA_FIVE_HOME=$(find /usr/lib -maxdepth 1 -name xulrunner-[0-9]* | head -1)
LD_LIBRARY_PATH={$MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}