PDA

View Full Version : problemi in configurazione e utilizzo Pentaho Bi Server - design studio - PAC



Vania75
11-14-2011, 06:11 AM
Salve a tutti.
Recentemente ho installato BI Server CE, versione 3.9.0, ed il Design Studio basato su Eclipse, versione ce-win-32-4.0.0 (e anche PDI 4.2.0), tutto su piattaforma Windows 2008 server. Versione JRE 6.0. Sto usando il db di esempio, che ho re-configurato per andare su database MySQL (per Hibernate, Quartz e SampleData).
Vorrei imparare a usare e fare una valutazione del prodotto per proporlo ad alcuni clienti orientati all'Open Source.
Premetto che non sono un'esperta Java (a voler usare un eufemismo), in effetti provengo da "mondo" Microsoft e in particolare BI Microsoft.
Ad ogni modo, nell'utilizzo della soluzione Pentaho sto riscontrando diversi problemi, e vorrei chiedervi qualche suggerimento. Faccio alcuni esempi:
- Sto cercando di imparare a creare XActions da Design Studio, tuttavia non riesco a capire cosa devo fare per vedere "aggiornarsi" il contenuto sul Portale Web. Infatti non riesco a capire con quale frequenza e/o criterio il Portale viene aggiornato, dato che a volte mi capita di dover semplicemente riavviare il Design Studio, altre volte di riavviare il BI-Server o addirittura la macchina e altre volte non riesco proprio a influire in nessun modo, e magari mi accorgo dopo un'ora che la modifica finalmente è stata "vista". Forse non ho compreso cosa è necessario fare per avere questo Refresh/pubblicazione delle XActions, potete aiutarmi?
- Ho installato la PAC web (quella che si scarica con il BI Server 3.9.0), e seguito le istruzioni di configurazione dal Wiki. Tuttavia, anche se riesco ad accedere al Portale, mi esce questa segnalazione di errore " Error loading database connections. Unable to refresh database connection list. The call failed on the server.". Dopo di chè non riesco a salvare nuovi ruoli o utenti o connessioni Database. L'unica cosa che riesco a salvare senza ottenere un messaggio di errore è una nuova Schedulazione (che però non funziona). Non ho idea su cosa dovrei poter fare e/o riconfigurare...
Vi ringrazio molto in anticipo per eventuali contributi.
Vania

Ivan_76
11-15-2011, 12:02 PM
Prova ad aumentare la "profondità di log" nel file log4j, magari nella sezione interessata, passa da "ERROR" a "DEBUG".

Attenzione che i log potrebbero aumentare copiosamente come dimensioni, in quanto in fase di debug viene loggata molta più roba, ma magari riescia trovare la soluzione al tuo problema.

Ciao

Vania75
11-21-2011, 10:07 AM
Ciao, ti ringrazio della risposta, mi sai indicare come fare ad aumentare questa profondità? Grazie

Ivan_76
11-21-2011, 12:29 PM
Prova a modificare i parametri di log4j, al posto di <ERROR>, puoi commentarlo, ed utilizzare <DEBUG>.

enricoe85
12-27-2011, 12:46 PM
Quando pubblichi un qualsiasi contenuto nel reporsitory (cartella pentaho-solutions), che esso sia un report o un xaction, devi accedere alla piattaforma via web e cliccare sull'icona "aggiorna". A quel punto il server fa un refresh dei contenuti che trova nel suo repository e tu dovresti vedere il nuovo contenuto. Quindi nel tuo caso, sviluppi la xactions con Eclipse, terminato lo sviluppo la copi nel repository del server e poi aggiorni. Spero di essere stato utile.

enricoe85
12-27-2011, 12:51 PM
Per quanto riguarda la PAC sicuramente da quello che hai riportato è un errore nella configurazione del nuovo database siccome sei passata a MySql. La PAC di default fa riferimento ad alcune tabelle del db Hibernate per la gestione degli utenti e dei gruppi e non riuscendo ad accedervi non puoi operare sugli stessi. Come già consigliato controlla i log e cerca di capire dov'è il problema, oppure semplicemente ce lo posti :)

Vania75
01-09-2012, 06:34 AM
Ciao Enrico, grazie mille per entrambe le risposte.
In effetti, per quel che riguarda la PAC, c'era un errore di configurazione, per quel che riguarda il connection pool (c3p0).
Ora funziona.