PDA

View Full Version : HBase Input error



amlan.roy
07-12-2012, 09:11 AM
I am trying to use Hbase Input in Spoon. My HBase cluster is using hbase-0.92.0 and hadoop-1.0.0. I have replaced the hadoop-core-0.20.2.jar and hbase-0.90.3.jar in PDI with the versions I use. But I get the following error. (I have made sure my cluster is up and running and I can fetch data using my client program.)

org.apache.hadoop.hbase.MasterNotRunningException: Retried 1 times
at org.apache.hadoop.hbase.client.HBaseAdmin.<init>(HBaseAdmin.java:127)
at org.apache.hadoop.hbase.client.HBaseAdmin.checkHBaseAvailable(HBaseAdmin.java:1551)
at org.pentaho.hbase.mapping.MappingAdmin.checkHBaseAvailable(MappingAdmin.java:131)
at org.pentaho.hbase.mapping.MappingEditor.populateTableCombo(MappingEditor.java:466)
at org.pentaho.hbase.mapping.MappingEditor.access$100(MappingEditor.java:88)
at org.pentaho.hbase.mapping.MappingEditor$3.focusGained(MappingEditor.java:231)
at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.notifyListeners(Unknown Source)
at org.eclipse.swt.custom.CCombo.handleFocus(Unknown Source)
at org.eclipse.swt.custom.CCombo.textEvent(Unknown Source)
at org.eclipse.swt.custom.CCombo$1.handleEvent(Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Control.sendFocusEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.wmSetFocus(Unknown Source)
at org.eclipse.swt.widgets.Control.WM_SETFOCUS(Unknown Source)
at org.eclipse.swt.widgets.Control.windowProc(Unknown Source)
at org.eclipse.swt.widgets.Text.windowProc(Unknown Source)
at org.eclipse.swt.widgets.Display.windowProc(Unknown Source)
at org.eclipse.swt.internal.win32.OS.SetFocus(Native Method)
at org.eclipse.swt.widgets.Control.forceFocus(Unknown Source)
at org.eclipse.swt.widgets.Control.setFixedFocus(Unknown Source)
at org.eclipse.swt.widgets.Composite.setFixedFocus(Unknown Source)
at org.eclipse.swt.widgets.Composite.setFixedFocus(Unknown Source)
at org.eclipse.swt.widgets.Composite.setFixedFocus(Unknown Source)
at org.eclipse.swt.widgets.Control.fixFocus(Unknown Source)
at org.eclipse.swt.widgets.Control.setVisible(Unknown Source)
at org.eclipse.swt.custom.CTabFolder.setSelection(Unknown Source)
at org.eclipse.swt.custom.CTabFolder.setSelection(Unknown Source)
at org.eclipse.swt.custom.CTabFolder.onMouse(Unknown Source)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(Unknown Source)

amlan.roy
07-14-2012, 02:19 PM
I am still unable to make it work. Not sure if it is a problem with my setup or some problem with Pentaho. I think my HBase cluster is fine since I can read and write data. Any help will be greatly appreciated.