Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Spoon wont launch

  1. #1
    Join Date
    Nov 2017
    Posts
    2

    Angry Spoon wont launch

    Just updated my Java to the latest (for this week) JRE1.8.0_151 and my spoon is still looking for the old version I had installed. I have updated all my environment variables, JRE_HOME, JAVA_HOME and PENTAHO_JAVA_HOME.

    When I try to start spoon from the Batch file it shows that it is still trying the load JRE1.8.0_141 is there somewhere that I am missing that I need to update something. I have 64bit Java installed and my Paths for all variables are C:\Program Files\Java\JRE1.8.0_151

    Spoonerr.jpg

  2. #2
    Join Date
    Nov 2017
    Posts
    2

    Default

    Quote Originally Posted by Arsenal101 View Post
    Just updated my Java to the latest (for this week) JRE1.8.0_151 and my spoon is still looking for the old version I had installed. I have updated all my environment variables, JRE_HOME, JAVA_HOME and PENTAHO_JAVA_HOME.

    When I try to start spoon from the Batch file it shows that it is still trying the load JRE1.8.0_141 is there somewhere that I am missing that I need to update something. I have 64bit Java installed and my Paths for all variables are C:\Program Files\Java\JRE1.8.0_151

    Spoonerr.jpg

    Well That's just wacked.... Renamed my JRE1.8.0_151 to JRE1.8.0_141 and Spoon started right up... Closed it. Went to start it again and got the same error as before but this time it's looking for 1.8.0_151!!!!!! So renamed folder back to 151 and Spoon works great now


    I DON'T GET IT..... but it works so I am happy

  3. #3
    Join Date
    Jun 2012
    Posts
    5,369

    Default

    You say you updated environment variable PENTAHO_JAVA_HOME.
    The second DEBUG line tells a different story, though.
    Enable console echo in script set-pentaho-env.bat to find out more.


    PS: You forgot to start Spoon from a new console window. Changes to enviroment variables are not visible to existing console windows
    pdi-ce user (mostly 4.4)
    java 1.8.0_131 (OpenJDK)
    ubuntu 16.04 LTS (x86_64)
    timezone CET / CEST
    contemplative reading SSCCE
    sig updated 2017-10-20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.