Hitachi Vantara Pentaho Community Forums
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Installing Pentaho on Ubuntu 10.04.

  1. #1

    Default Installing Pentaho on Ubuntu 10.04.

    Hi Everyone,

    Great tips on these forums! Thank you all for that!

    I am installing Pentaho biserver-ce 3.7 on an Ubuntu 10.04 box, following Prashant Raju's guide. Which is a must read for every newbie (like me):

    I ran into a few issue's up till now, let me share them with you:

    1. I installed as much with apt-get as possible (makes updating much easier).
    2. To get sun java 6 you need to add a reporistory:
    sudo apt-get python-stofware-properties
    sudo add-apt-repository "deb lucid partner"
    sudo apt-get update
    3. Now install sun java6, tomcat6, mysql-server
    sudo apt-get install sun-java6-jdk sun-java6-jre mysql-server tomcat6 libmysql-java
    4. You have the latest mysql-java-connector on your system now, so don't copy the connector as in the guide of Prashant.
    5. Put a symlink in the tomcat/lib directory directory to the connector:
    sudo ln -s /usr/share/java/mysql-connector-java-X.X.XX.jar /usr/share/tomcat6/lib/mysql.jar
    6. The tomcat webapps dir is not where Prashant says it is, so I made another symlink:
    sudo mkdir /opt/tomcat/webapps
    cd /var/lib/tomcat6
    rm -rf webapps
    ln -s /opt/tomcat/webapps /var/lib/tomcat6/webapps
    7. Add the home directories and catalina opts to /etc/environment
    CATALINA_OPTS="-Xms256m -Xmx768m -XX:MaxPermSize=256m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000"
    Don't forget to source /etc/environment again!
    8. I want to connect from different places the mysql server, so I hashed bind-address in /etc/mysql/my.cnf
    9. Restart the mysql server and stop tomcat
    sudo /etc/init.d/mysql restart
    sudo /etc/init.d/tomcat6 stop
    10. Follow Prashant's guide
    11. For some reason the pentaho.log file needs to have a fixed address, edit /opt/tomcat/webapps/pentaho/WEB-INF/classes/log4j.xml I changed pentho.log to
    So now all my tomcat logs are in /var/log/tomcat6
    12. Change the owner of everything in the /opt folder to the tomcat user:
    sudo chown -R tomcat6:tomcat6 /opt/pentaho
    sudo chown -R tomcat6:tomcat6 /opt/tomcat
    12. Start tomcat again
    sudo /etc/init.d/tomcat6 start
    13. The BI Server works! Although with errors Looking into solving this error now:
    Unable to create default file : /usr/share/tomcat6/.kettle/
    I'll check back in when I solve this, if anyone has got an idea in the meantime, please let me know!
    Last edited by martijnburger; 02-08-2011 at 08:08 AM.

  2. #2
    Join Date
    Jun 2007


    Hi Martin,

    You have been going through the same stuff I have just been doing. And stopped at the same place! I am going to have a crack at the kettle stuff this weekend and see what I come up with. I noticed too that some of the reports in the Steel Wheels example wont run. I am not sure if this is just me or if there is a more fundamental issue here. So far I must say though that I am loving the stability of Pentaho & MySQL on Ubuntu 10.4 Server. Its good to see I am not alone!

    I'll check back with you next week.


    The Frog.

    PS: There is also some stupid HSQLDB crap that Tomcat6 makes a copy of (no idea why) in a file called Pentaho.xml. You may also need to edit this file and remove the HSQLDB references and swap them to MySQL instead.
    Everything should be made as simple as possible, but not simpler - Albert Einstein

  3. #3
    Join Date
    Jun 2007


    Had a bit of a dif through and discovered a few issues with the install. Several components are failing, and they seem to be centered around two areas. One is kettle and the other is reporting.

    Poking around the logs and digging around the file system there seems to be an issue with the
    This seems to stem from the fact that there is no actual repository specified, and when it goes looking for one on teh 'default' location there isnt one there. I am going to play with the file and try to relocate the repository specified to the actual repository I am using. If this works then the kettle problem goes away. I will report back when done (finding time is a pain at the moment).

    The reporting based stuff seems to stem from something to do with a combination of missing files (library files I am assuming) and also some screwed up fonts. I dont know if this is an Ubuntu thing or not. I will assume for the moment that the fonts are simply something like version issues and maybe just copying the files from the CE version to the deployed version will solve that. As for the potentially missing lib files I need to dig some more to figure it out.


    The Frog
    Everything should be made as simple as possible, but not simpler - Albert Einstein

  4. #4
    Join Date
    Jun 2007

    Cool Kettle part solved

    OK, the kettle stuff is simply this: The
    file needs to be told about how to login to a repository. That means you need to change the repository type from files to
    and provide the name of the repository to use.

    The way I did this was to take my .kettle folder and copy it to /usr/share/tomcat6 (and give the tomcat6 user ownership). When you copy this all your repository info comes along for the ride (this is all your spoon settings). Just make sure that the name of the repository you want to use (ie/ the connection you set up in spoon) is able to actually be reached by the machine you are running all this on.

    There are two other things I have noticed in the logs:
    12:44:59,095 WARN [PackageState] Unable to initialize the module misc-configstore-filesystem
    12:44:59,221 WARN [PackageState] Unable to initialize the module ext-datasources-sampledata
    I will have to dig around a bit for these too. Or if someone already knows what they are.....


    The Frog
    Everything should be made as simple as possible, but not simpler - Albert Einstein

  5. #5


    Hey The Frog,

    great to hear that I am not alone with my 'challenges'.

    I created the .kettle directory and chowned it to tomcat6:tomcat6 and it makes the error go away. I am having the exact same errors. A list of font warnings and the two module warnings. Two things:

    1. I did not edit the kettle settings.xml. It is still files, any idea why I should change that?
    2. For everyone struggeling, I had another persistence error, simple uncomment in var/lib/tomcat6/conf/context.xml
    <Manager pathname="" />


  6. #6


    Hi Martijn,

    I am trying to do the same thing:
    pentaho on ubuntu 10.04 with postgresql

    but it seems i cannot get the tomcat server that is in the biserver pack to start...

    The BASEDIR environment variable is not defined correctly
    This environment variable is needed to run this program

    This looks to me as a tomcat thing, did you install tomcat by itself first?


  7. #7


    Hi Hugo,

    yes, I did a package install of tomcat and symlinked the pentho, pentaho-solutions, etc. to the tomcat6 webapps dir. I don't use the startup script provided, just start tomcat and the pentaho webapp is started too.

  8. #8


    yep mine is up now too!

  9. #9



    great! Anything strange in the /var/log/tomcat6/catalina.out or the pentaho.log?

  10. #10


    @ step 11 : I do not have a /system dir in WEB-INF
    I have no pentaho.log file in var/log/tomcat6 ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.