Hi: I´m just beginning with to work with metadata editor, although I´ve some experience with kettle and the schema workbench
I started a small proyect to begin with, imported tables, made the relationships and buisness views with no problems when I tried to export to xmi file. Then I tried to increase the number of tables, and when I imported some of them, and tried to export to xmi, I got the error:

"javax.jmi.reflect.InvalidObjectException: Object with MOFID 4CB5D5D1-E2FA-11E1-B2B0-C2849F45AA77:00000000000CCD8E no longer exists, class: org.pentaho.pms.cwm.pentaho.meta.businessinformation.CwmDescription$Impl"

So I thought the problem was in these new tables, but I restarted the Metadata Editor, and then SOME of the tables that where causing problems no longer did, and some of the ones that where working just fine did not any more
I did this a lot of times, restarting the program, restarting windows, using a different database, etc... and the error seems to be totaly random.
I´m using win7, mySql 5.5 with a 8mb, 4.2Mhz PC
the details of the error are:

at org.netbeans.lib.jmi.xmi.SAXReader.read(SAXReader.java:62)
at org.pentaho.pms.core.CWM.importFromXMI(CWM.java:1433)
at org.pentaho.pms.core.CWM.importFromXMIString(CWM.java:1440)
at org.pentaho.pms.core.CWM.exportToXMI(CWM.java:1368)
at org.pentaho.pms.ui.MetaEditor.exportToXMI(MetaEditor.java:710)
at org.pentaho.pms.ui.MetaEditor.exportToXMI(MetaEditor.java:665)
at org.pentaho.pms.ui.MetaEditor$15.handleEvent(MetaEditor.java:535)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.pentaho.pms.ui.MetaEditor.readAndDispatch(MetaEditor.java:851)
at org.pentaho.pms.ui.MetaEditor.main(MetaEditor.java:3589)

Thanks in advance for the help

El Multiversista