Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: SOAP Call returns HTTP Codes (505, 501)

  1. #1
    Join Date
    Aug 2012
    Posts
    2

    Exclamation SOAP Call returns HTTP Codes (505, 501)

    When using the SOAP Call step in Kettle, trying to post several xml messages (generated with the Modified Java Script Value step) sequently, only the first 2 messages return a correct result (http response code 200).
    All other input xml messages generate a http response code 505 or 501:

    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : Unexpected error
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : org.pentaho.di.core.exception.KettleException:
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : Exception calling web service
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) :
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : Received response code '505' : something went wrong during the web service call!
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) :
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) :
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) :
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : at org.pentaho.di.plugin.soapui.SoapCall.processRow(SoapCall.java:125)
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : at org.pentaho.di.trans.step.RunThread.run(RunThread.java:40)
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : at java.lang.Thread.run(Unknown Source)
    2012/08/30 16:40:44 - SOAP Call Srch NIXIE.0 - ERROR (version 4.2.1-stable, build 15952 from 2011-10-25 15.27.10 by buildguy) : Caused by: org.pentaho.di.core.exception.KettleException:

    When analyzing the http-traffic it seems that after 2 calls the xml messages are posted too fast, leading to incorrect input for the soap webservice.

    Can this be influenced (e.a. post 1 call, wait for response and then post next call)???

    Thanks for your help!!!

    Kind regards

    Marc Kliffen

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Quote Originally Posted by MarcKliffen View Post
    Can this be influenced (e.a. post 1 call, wait for response and then post next call)?
    That's the way it already works. If row processing wouldn't wait for the response, you would need an event handler for asynchronous processing, see?

    If the web service needs a rest after each request, try the "Delay row" utility step.
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Aug 2012
    Posts
    2

    Default

    Quote Originally Posted by marabu View Post
    That's the way it already works. If row processing wouldn't wait for the response, you would need an event handler for asynchronous processing, see?

    If the web service needs a rest after each request, try the "Delay row" utility step.

    Thanks! Unfortunately, the SOAP Call keeps throwing the HTTP Codes 501 and 505. After reading 3 records, it writes 2 and quits.
    I attached the transformation I'm working, maybe I'm doing something wrong?
    Attached Files Attached Files

  4. #4
    Join Date
    Jun 2013
    Posts
    2

    Default Received response code '501' : something went wrong during the web service call!

    Quote Originally Posted by MarcKliffen View Post
    Thanks! Unfortunately, the SOAP Call keeps throwing the HTTP Codes 501 and 505. After reading 3 records, it writes 2 and quits.
    I attached the transformation I'm working, maybe I'm doing something wrong?
    Hi,

    I am getting same Error as above. While I am trying to insert 6 records from SQL Server to MySQL using "Soap Call Step", it inserts only 2 records then giving below error.
    Even though I used "Delay row" utility step.
    is PDI not able to perform "Soap Call Step" properly? or is there any other configuration/utility step missing?

    I attached the Transformation (.ktr) file.

    2013/06/19 15:07:20 - Spoon - Transformation opened.
    2013/06/19 15:07:20 - Spoon - Launching transformation [TableSQLServToMySql_AxisObjectInputs]...
    2013/06/19 15:07:20 - Spoon - Started the transformation execution.
    2013/06/19 15:07:20 - TableSQLServToMySql_AxisObjectInputs - Dispatching started for transformation [TableSQLServToMySql_AxisObjectInputs]
    2013/06/19 15:07:20 - Transformation metadata - Natural sort of steps executed in 0 ms (5 time previous steps calculated)
    2013/06/19 15:07:20 - Table input.0 - Finished reading query, closing connection.
    2013/06/19 15:07:20 - Table input.0 - Finished processing (I=3, O=0, R=0, W=3, U=0, E=0)
    2013/06/19 15:07:20 - Generate SOAP request.0 - Finished processing (I=0, O=0, R=3, W=3, U=0, E=0)
    2013/06/19 15:07:26 - Delay row.0 - Finished processing (I=0, O=0, R=3, W=3, U=0, E=0)
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Unexpected error
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : org.pentaho.di.core.exception.KettleException:
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Exception calling web service
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Received response code '501' : something went wrong during the web service call!
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : at org.pentaho.di.plugin.soapui.SoapCall.processRow(SoapCall.java:125)
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : at org.pentaho.di.trans.step.RunThread.run(RunThread.java:40)
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : at java.lang.Thread.run(Thread.java:662)
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Caused by: org.pentaho.di.core.exception.KettleException:
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Received response code '501' : something went wrong during the web service call!
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) :
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : at org.pentaho.di.plugin.soapui.SoapCall.processRow(SoapCall.java:122)
    2013/06/19 15:07:26 - SOAP Call.0 - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : ... 2 more
    2013/06/19 15:07:26 - SOAP Call.0 - Finished processing (I=0, O=0, R=3, W=2, U=0, E=1)
    2013/06/19 15:07:26 - TableSQLServToMySql_AxisObjectInputs - TableSQLServToMySql_AxisObjectInputs
    2013/06/19 15:07:26 - TableSQLServToMySql_AxisObjectInputs - TableSQLServToMySql_AxisObjectInputs
    2013/06/19 15:07:26 - Parse SOAP Response.0 - Finished processing (I=0, O=0, R=2, W=2, U=0, E=0)
    2013/06/19 15:07:26 - Spoon - The transformation has finished!!
    2013/06/19 15:07:26 - TableSQLServToMySql_AxisObjectInputs - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Errors detected!
    2013/06/19 15:07:26 - TableSQLServToMySql_AxisObjectInputs - ERROR (version 4.2.0-stable, build 15748 from 2011-09-08 13.11.42 by buildguy) : Errors detected!


    Please Help me to resolve the issue.
    Thanks in Advance.


    Surender.
    Attached Files Attached Files
    Last edited by Surender; 06-21-2013 at 05:04 AM.

  5. #5
    Join Date
    Jun 2013
    Posts
    2

    Default

    Can anybody faced the same type of problem? and
    Can anybody resolved this problem?
    Please help.

  6. #6
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    There seems to be a problem on the server side, so you should look there for explanation.

    It is always a good idea to verify SOAP communication with a tool like SoapUI, before scratching your head over Kettle.
    So long, and thanks for all the fish.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.