Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Add Constant-Step has no effect

  1. #1

    Thumbs down Add Constant-Step has no effect

    Hi guys out there,

    since I am not able to reply on any topic (don´t know why, none of my posts get published allthough they do not have any spam or other cruel content) I open a new one here.

    My current problem is, that when I chain several steps (in my case "get File Name"-Steps) and combining them with an "add constant"-field as suggested here the constant is not found. I always get the error:
    We can not find Field [{0}] in the input stream! [Mask]
    where Mask is the name of the constant. I also tried it by adding the constant to a "modified javascript"-step without any success (error: ReferenceError: "Mask" is not defined. (script#1)).

    It seems to be bugged since the step is completely of no use.

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Just give it input and it will add the specified fields to the output. That's all there is to it.
    The "Add Constants" step is one of the most simple steps out there. I would be severely surprised if it didn't work.

  3. #3

    Default

    After a few hours of frustration I believe I finally managed the issue. I admitted, that the step should not be chained (like all the others) but added as a further input to the next step. This means the next step would have got 2 inputs instead of one single.
    It seems I´m a real newbi on these topicss... but now it works - so far...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.