Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: why the webservice lookup input is null?

  1. #1
    Join Date
    Sep 2012
    Posts
    1

    Default why the webservice lookup input is null?

    My kettle verson is V4.3.0, I used "Get Fields" or "Load" button got input parameters at "in" tabpage, but it's return the WS Name is parameters, if i change WS Name to inputXml then i can not get input value when i invoke the web services. the soap request is <ns:askProtocolCapability> </ns:askProtocolCapability>, no <ns:inputXml> tags found. why? but i keep WS Name is "parameters" i got these errors as following:


    That's fragment of my running log:

    Web services lookup.0 - <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns="http://www.zhhy.com">
    <soapenv:Header>
    </soapenv:Header>
    <soapenv:Body>
    <ns:askProtocolCapability>
    <parameters><INPUT><PROTOCOL_CATEGORY>1000</PROTOCOL_CATEGORY></INPUT></parameters>
    </ns:askProtocolCapability>
    </soapenv:Body>
    </soapenv:Envelope>
    2012/09/18 16:55:02 - Web services lookup.0 - Using SOAP Action string ["http://www.zhhy.com/askProtocolCapability"] in the request header.
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : Unexpected error
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : org.pentaho.di.core.exception.KettleStepException:
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : Internal server error while calling the web service. Service URL=http://localhost:8080/onspotcomm/HYServices, Response code = 500.
    Response body: <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/enve...>Unmarshalling Error: unexpected element (uri:"", local:"parameters"). Expected elements are &lt;{}inputXml> </faultstring></soap:Fault></soap:Body></soap:Envelope>
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) :
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : at org.pentaho.di.trans.steps.webservices.WebService.requestSOAP(WebService.java:448)
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : at org.pentaho.di.trans.steps.webservices.WebService.processRow(WebService.java:187)
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : at org.pentaho.di.trans.step.RunThread.run(RunThread.java:50)
    2012/09/18 16:55:02 - Web services lookup.0 - ERROR (version 4.3.0-stable, build 16786 from 2012-04-24 14.11.32 by buildguy) : at java.lang.Thread.run(Thread.java:662)
    2012/09/18 16:55:02 - Web services lookup.0 - Finished processing (I=0, O=0, R=1, W=0, U=0, E=1)
    Last edited by fredjin; 09-18-2012 at 11:41 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.