Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: PDI/Kettle CE won't run on Mac OS X 10.8, unless...

  1. #1
    Join Date
    Sep 2012
    Posts
    1

    Default PDI/Kettle CE won't run on Mac OS X 10.8, unless...

    ...unless you fix a missing x flag.

    After download, right-click on Data Integration 64-bit (or 32-bit), show package content, navigate down to MacOS and go into terminal there (drag the MacOS folder onto the Terminal application) and "chmod a+x JavaApplicationStub". Boom. The program will now launch properly on Mountain Lion.

  2. #2

  3. #3
    Join Date
    Sep 2012
    Posts
    1

    Default How to fix

    Quote Originally Posted by ejeklint View Post
    ...unless you fix a missing x flag.

    After download, right-click on Data Integration 64-bit (or 32-bit), show package content, navigate down to MacOS and go into terminal there (drag the MacOS folder onto the Terminal application) and "chmod a+x JavaApplicationStub". Boom. The program will now launch properly on Mountain Lion.
    This didn't work for me on 10.8.2 with PDI 4.2.0-stable, here's what I did:

    1. opened System Preferences
    2. clicked Security and Privacy
    3. click the lock to make changes in the "general" tab
    4. selected "Allow applications from Anywhere"
    5. went back to my Data Integration 64-bit.app, double clicked, agreed to the executable warning. Kettle should launch properly.
    6. back in the Security and Privacy settings, you can switch it back to "Mac Store and Identified Developers" once you have launched kettle once, and it will launch properly the next time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.