Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Published new metadata model but connection does not exist in User console

  1. #1

    Default Published new metadata model but connection does not exist in User console

    I succesfully published a new metadatamodel to a new publication folder. However when I use this to build a new interactive report in the user console I can select this model, but no dataconnection exists. I tried to add a connection through the admin console, but that seems to allow only mysql type connections. In this case the connection used in metadata editor is to MS SQL server.

    Do I need to add drivers to be able to create a new DB connection?

  2. #2
    Join Date
    Nov 2009
    Posts
    688

    Default

    Place a driver for mssql in the good directory's

    • BA Server: /pentaho/server/biserver-ee/tomcat/lib/
    • Enterprise Console: /pentaho/server/enterprise-console/jdbc/
    • Data Integration Server: /pentaho/server/data-integration-server/tomcat/webapps/pentaho-di/WEB-INF/lib/
    • Data Integration client: /pentaho/design-tools/data-integration/libext/JDBC/
    • Report Designer: /pentaho/design-tools/report-designer/lib/jdbc/
    • Schema Workbench: /pentaho/design-tools/schema-workbench/drivers/
    • Aggregation Designer: /pentaho/design-tools/agg-designer/drivers/
    • Metadata Editor: /pentaho/design-tools/metadata-editor/libext/JDBC/

  3. #3

    Default Setting the connection

    Quote Originally Posted by johanhammink View Post
    Place a driver for mssql in the good directory's

    • BA Server: /pentaho/server/biserver-ee/tomcat/lib/
    • Enterprise Console: /pentaho/server/enterprise-console/jdbc/
    • Data Integration Server: /pentaho/server/data-integration-server/tomcat/webapps/pentaho-di/WEB-INF/lib/
    • Data Integration client: /pentaho/design-tools/data-integration/libext/JDBC/
    • Report Designer: /pentaho/design-tools/report-designer/lib/jdbc/
    • Schema Workbench: /pentaho/design-tools/schema-workbench/drivers/
    • Aggregation Designer: /pentaho/design-tools/agg-designer/drivers/
    • Metadata Editor: /pentaho/design-tools/metadata-editor/libext/JDBC/
    I succesfully added a connection in the administration console. In the user console , when creating an interactive report I can select the published metadata model, but when dragging an item into the report :

    An unexpected error has occurred: Unable to create a connection

    It seems each design tools allows for creating it's own datasource connection, but the metadata editor connection does not work elsewhere. Very confusing..

  4. #4

    Default

    I have the same problem, did you finally find a solution to it??

  5. #5
    Join Date
    Nov 2014
    Posts
    2

    Default

    Quote Originally Posted by blom0344 View Post
    I succesfully added a connection in the administration console. In the user console , when creating an interactive report I can select the published metadata model, but when dragging an item into the report :

    An unexpected error has occurred: Unable to create a connection

    It seems each design tools allows for creating it's own datasource connection, but the metadata editor connection does not work elsewhere. Very confusing..
    I am still running into this issue. Does anyone know of a solution. Any help would be greatly appreciated.

    Thanks,
    wjpatton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.