Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Inline emails in Outlook 2007/2010

  1. #1
    Join Date
    Feb 2012
    Posts
    14

    Default Inline emails in Outlook 2007/2010

    I have a couple of reports that I'm sending as an inline HTML email. The reports look fine in the browser, but when I open them in Outlook some of the columns are the wrong width.

    I did a bit of research and it looks like Outlook is using the horribly outdated MS Word engine to render the HTML with limited CSS support. See this link for more info: http://sxates.com/design/tips-and-be...ook-2007-2010/

    Has anyone encountered this issue and if so, did you find any workarounds?

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Our HTML export uses a horribly old way of generating HTML, that should perfectly match the horrible nature of Outlook. All our HTML exports are HTML tables with only basic CSS requirements.

    However, most "Columns with the wrong width" problems can be fixed by properly layouting the elements. Each top and left edge of an element produces a new column or row. If you enable strict mode (via the report configuration), also the bottom and right edge will produce a new column or row.

    But if you have elements that are only slightly misplaced, you can end up with visible artefacts as the elements will start sitting on different row/column positions.

    You can see a rough guestimate of the table-cell-edges by enabling the menu-option "View->Element Alignment Hints".
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    Feb 2012
    Posts
    14

    Default

    So I got everything lined up. It works fine, except that Outlook is not respecting the table/column widths I've defined.

    I have six columns all with the same width, the x-overflow is false and the y-overflow is true. For some reason Outlook is always ignoring the x-overflow = false and increasing the column width. Any ideas?

  4. #4
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Could it be that you have the report-configuration propery "org.pentaho.reporting.engine.classic.core.modules.output.table.html.ProportionalColumnWidths" set to true? (Check the generated HTML content. If the table-cols have a width in % then the property is true).

    Set it to false (via File->Report Configuration) and you may have better reports.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  5. #5
    Join Date
    Feb 2012
    Posts
    14

    Default

    I had it set to the default (false), but I went ahead and set it explicitly. The report still looked the same. My column widths are set in pt widths in the generated HTML.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.