Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: MDX Query Error (Schema Workbench)

  1. #1

    Default MDX Query Error (Schema Workbench)

    Hi,

    I've made a simple schema with the schema workbench, made by the fact table, a dimension and a measure. I've there's no errors at the schema but when executing MDX Query it jumps this error:

    "Exception: Mondrian Error:Level 'New Level 0' must have a name expression (a 'column' attribute or an <Expression> child


    See workbench log for full stacktrace."

    I've been looking forward the error but found nothing. Actually I don't have a Level called 'New Level 0', I renamed the level to CUSTOMER_ID just after creating it, but there are no other levels where the error could be...

    In my Level I've defined the name, table, columns, Type and internal type.

    Anyone knows where to search the error?

    Thanks in advanced,

    MontiJr

  2. #2

    Default

    Problem solved, today I started the Schema Workbench and I executed again the MDX Query just to try, and suspiciusly worked... .-.

  3. #3

    Default

    A possible reason for this could be Schema Workbench needs you to change focus in the interface (e.g., select a different Dimension, input field, whatever) before a change to the current input field is detected as 'change'. So basically, when you change some field, press Ctrl + S and execute an MDX query your schema file might not actually have been changed because Schema Workbench did not detect the change yet and thus did not save it.

    At least I've ran into behavior like this occasionally =)

  4. #4

    Default

    Thanks for the appointment, now I'm sure that was the problem that I had ^^

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.