Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: xmla of version 3.5.0 not working

  1. #1
    Join Date
    Dec 2012
    Posts
    1

    Default xmla of version 3.5.0 not working

    Dear Sir/Madam,

    Shall I still put the full path of Datasources.xml in the section DataSourcesConfig of web.xml?
    Else, I will got "invalid URL path '/WEB-INF/datasources.xml'"

    However, when I changed it to full path, I will got the error:

    Failed to parse data sources config 'null'.Any ideas?Thanks.Jeffers

  2. #2
    Join Date
    Jan 2013
    Posts
    2

    Default

    Hi,

    I have the same issues as yours, I try to modify web.xml but don't work.

    case1 : modify "mondrian.xmla.impl.DynamicDatasourceXmlaServlet" value, fail!

    <servlet> <servlet-name>MondrianXmlaServlet</servlet-name> <servlet-class>mondrian.xmla.impl.DynamicDatasourceXmlaServlet</servlet-class> <init-param> <param-name>DataSourcesConfig</param-name> <param-value>http://localhost:8080/WEB-INF/datasource.xml</param-value> </init-param> </servlet>case 2: mark the "mondrian.xmla.impl.DynamicDatasourceXmlaServlet" value,
    run the mondrian FoodMart demo, generate some new errors.


    <servlet> <servlet-name>MondrianXmlaServlet</servlet-name> <servlet-class>mondrian.xmla.impl.DynamicDatasourceXmlaServlet</servlet-class>
    <!-- <init-param> <param-name>DataSourcesConfig</param-name> <param-value>http://localhost:8080/WEB-INF/datasource.xml</param-value> </init-param>
    --> </servlet>

    I reference the following posting,
    http://lists.pentaho.org/pipermail/m...ry/003718.html

    If you slove the problem please share the answer. Thanks in advance!

    Sean

  3. #3
    Join Date
    Jan 2013
    Posts
    2

    Default

    Dear Jeffers,

    I have the same xmla errors.

    Reference the posting "http://lists.pentaho.org/pipermail/mondrian/2012-February/003718.html"

    I try case-1 : modify the web.xml "mondrian.xmla.impl.DynamicDatasourceXmlaServlet" parameter
    my web.xml file
    .....
    <servlet>
    <servlet-name>MondrianXmlaServlet</servlet-name>
    <servlet-class>mondrian.xmla.impl.DynamicDatasourceXmlaServlet</servlet-class>
    <init-param>
    <param-name>DataSourcesConfig</param-name>
    <param-value>http://localhost:8080/mandrian/WEB-INF/datasources.xml</param-value>
    </init-param>
    </servlet>
    ......
    Fail!

    Try case-2 : disable the "DataSourcesConfig" parameter
    my web.xml file
    .....
    <servlet>
    <servlet-name>MondrianXmlaServlet</servlet-name>
    <servlet-class>mondrian.xmla.impl.DynamicDatasourceXmlaServlet</servlet-class>

    <!-- mark the parameters
    <init-param>
    <param-name>DataSourcesConfig</param-name>
    <param-value>http://localhost:8080/mandrian/WEB-INF/datasources.xml</param-value>
    </init-param>
    -->
    </servlet>
    ......

    Run the FoodMart demo web page http://localhost:8080/mondrian/,
    Click "XML for Analysis tester" link, it display the xml data but can't open FoodMart database.

    If you solve the error, please share your answer.
    Thanks in advance.

    Sean

  4. #4
    Join Date
    Mar 2014
    Posts
    7

    Default

    I finally got this to work.

    What I did was:

    1. copy datasources.xml from webapps\mondrian\WEB-INF to webapps\mondrian.
    2. Change web.xml accordingly:
    <init-param>
    <param-name>DataSourcesConfig</param-name>
    <param-value>http://localhost:8080/mondrian/datasources.xml</param-value>
    </init-param>
    Last edited by wessman; 03-09-2014 at 07:18 AM. Reason: problem solved

  5. #5
    DEinspanjer Guest

    Default

    Awesome, thank you very much for the followup wessman!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.