I think I lost something even after following many tutorials to compile my own code.

In the module bi-platform-security-userroledao, package org.pentaho.platform.engine.security.userroledao.userrolelistservice, there is a class UserRoleDaoUserRoleListService.

For testing my own implementation, I created a class just like UserRoleDaoUserRoleListService in the same package. With the same attributes and codes. Just changed the name.

After that I compiled(typing ant) the module bi-platform-security-userroledao and it was generated the file class JustTestMYClass.

So, in the file pentaho-solutions\system\applicationContext-spring-security-hibernate.xml

and in the file pentaho-solutions\system\applicationContext-pentaho-security-hibernate.xml

I made this alteration(where JustTestMYClass is the class that i created):
<bean id="userDetailsService"  class="org.pentaho.platform.engine.security.userroledao.userdetailsservice.JustTestMYClass">  
    <property name="userRoleDao"> 
      <ref local="userRoleDao" /> 
And then I followed that link:

And tried the 2 ways that the tutorial suggests. Thoroughly. And always when I run pentaho, appear the same message

org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.pentaho.platform.engine.security.userroledao.userdetailsservice.JustTestMYClass] for bean with name 'userDetailsService'

But the class is compiled and it is there in the module. I don't understand what happens.