Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Compiling mantle

  1. #1

    Default Compiling mantle

    Hello,
    I'm trying to build mantle of the bi-server 4.8 CE.
    I am using the eclipse project found at http://source.pentaho.org/svnroot/bi....8.0-GA/mantle.
    I execute the build.xml's target "resolve" which fails with following:



    Code:
    [ivy:resolve]     com.google.gwt#gwt-user;1.5.3 by [com.google.gwt#gwt-user;2.0.3] in [codegen]
        ---------------------------------------------------------------------
        |                  |            modules            ||   artifacts   |
        |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
        ---------------------------------------------------------------------
        |      codegen     |  157  |   26  |   21  |   18  ||  137  |   23  |
        ---------------------------------------------------------------------
    [ivy:resolve] :: problems summary ::
    [ivy:resolve] :::: WARNINGS
    [ivy:resolve]         module not found: com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     ==== local: tried
    [ivy:resolve]       C:\Documents and Settings\User\.ivy2/local/com.google.gwt/gwt-dev/2.0.3/ivys/ivy.xml
    [ivy:resolve]       -- artifact com.google.gwt#gwt-dev;2.0.3!gwt-dev.jar:
    [ivy:resolve]       C:\Documents and Settings\User\.ivy2/local/com.google.gwt/gwt-dev/2.0.3/jars/gwt-dev-2.0.3.jar
    [ivy:resolve]     ==== pentaho-ivy: tried
    [ivy:resolve]       http://repo.pentaho.org/artifactory/...-2.0.3.ivy.xml
    [ivy:resolve]     ==== pentaho-mvn: tried
    [ivy:resolve]       http://repo.pentaho.org/artifactory/...-dev-2.0.3.pom
    [ivy:resolve]       -- artifact com.google.gwt#gwt-dev;2.0.3!gwt-dev.jar:
    [ivy:resolve]       http://repo.pentaho.org/artifactory/...-dev-2.0.3.jar
    [ivy:resolve]     ==== public: tried
    [ivy:resolve]       http://repo1.maven.org/maven2/com/go...-dev-2.0.3.pom
    [ivy:resolve]     ==== java-net-maven2: tried
    [ivy:resolve]       http://download.java.net/maven/2/com...-dev-2.0.3.pom
    [ivy:resolve]       -- artifact com.google.gwt#gwt-dev;2.0.3!gwt-dev.jar:
    [ivy:resolve]       http://download.java.net/maven/2/com...-dev-2.0.3.jar
    [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:resolve]         ::          UNRESOLVED DEPENDENCIES         ::
    [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:resolve]         :: pentaho-kettle#kettle-engine;4.4.0-SNAPSHOT: configuration not found in pentaho-kettle#kettle-engine;4.4.0-SNAPSHOT: 'runtime'. It was required from pentaho#pentaho-bi-platform-engine-services;4.6-SNAPSHOT default-ext
    [ivy:resolve]         :: pentaho-kettle#kettle-core;4.4.0-SNAPSHOT: configuration not found in pentaho-kettle#kettle-core;4.4.0-SNAPSHOT: 'runtime'. It was required from pentaho#pentaho-bi-platform-engine-services;4.6-SNAPSHOT default-ext
    [ivy:resolve]         :: log4j#log4j;1.2.16: configuration not found in log4j#log4j;1.2.16: 'compile'. It was required from pentaho#pentaho-bi-platform-plugin-services;4.6-SNAPSHOT default-ext
    [ivy:resolve]         :: commons-lang#commons-lang;2.4: configuration not found in commons-lang#commons-lang;2.4: 'master'. It was required from pentaho#mondrian;TRUNK-SNAPSHOT default
    [ivy:resolve]         :: com.google.gwt#gwt-dev;2.0.3: not found
    [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:resolve] 
    [ivy:resolve] :::: ERRORS
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve]     impossible to acquire lock for com.google.gwt#gwt-dev;2.0.3
    [ivy:resolve] 
    [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
    
    
    BUILD FAILED
    D:\My documents\bi-workspace\mantle\build-res\subfloor-gwt.xml:137: impossible to resolve dependencies:
        resolve failed - see output for details
    Am I missing something?
    Thanks in advance.

  2. #2

    Default

    Bump :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.