Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Critical: Date Range in Where Clause in CDA doesn't work

  1. #1

    Default Critical: Date Range in Where Clause in CDA doesn't work

    Guys,

    Request you to please see this. Though I was able to solve this by holding my ear other way round, but its a very odd error. I am not sure if I put more parameters in the where clause and it might break. I would know during the course of this project. Since I am basing the entire architecture on CDA this time, I am hoping there are no blockers which dont have a workaround.. Need help and support from you guys..


    1. CDA MDX Query That Doesnt Work with Date Range


    2. with member [HomePlanUser].[Plan] as 'Sum({[HomePlanUser].[020]})'
    3. member [HomePlanUser].[Comparison] as 'Sum({[HomePlanUser].[020]})'
    4. member [HomePlanUser].[Tier 1] as 'Sum({[Tier].[Tier 1]})'
    5. select NON EMPTY {Hierarchize({[Measures].[Analyzed Episodes], [Measures].[Typical Cost], [Measures].[Complication Cost], [Measures].[Relevant Cost], [Measures].[Avg Typical], [Measures].[Avg Complication], [Measures].[Avg Relevant], [Measures].[Percent Complication Cost], [Measures].[Complication Rate], [Measures].[Readmission Episodes], [Measures].[Readmission Cost], [Measures].[Readmission Rate]})} ON COLUMNS,
    6. NON EMPTY Crossjoin({[Condition].[Colonoscopy]}, {[HomePlanUser].[Plan], [HomePlanUser].[Comparison], [HomePlanUser].[Tier 1]}) ON ROWS
    7. from [Episode]
    8. where {([Date].[2010].[Q1 2010] : [Date].[2011].[Q1 2011])}

    9. Error Log Here - http://pastebin.com/K5A9MkrT



    10. CDA MDX Query that works with Date Range


    11. with member [HomePlanUser].[Plan] as 'Sum({[HomePlanUser].[020]})'
    12. member [HomePlanUser].[Comparison] as 'Sum({[HomePlanUser].[020]})'
    13. member [HomePlanUser].[Tier 1] as 'Sum({[Tier].[Tier 1]})'
    14. member [Date].[Range] as 'Sum({([Date].[2010].[Q1 2010] : [Date].[2011].[Q1 2011])})'
    15. select NON EMPTY {Hierarchize({[Measures].[Analyzed Episodes], [Measures].[Typical Cost]})} ON COLUMNS,
    16. NON EMPTY Crossjoin({[Condition].[Colonoscopy]}, {[HomePlanUser].[Plan], [HomePlanUser].[Comparison], [HomePlanUser].[Tier 1]}) ON ROWS
    17. from [Episode]
    18. where [Date].[Range]

  2. #2
    Join Date
    Jul 2007
    Posts
    2,497

    Default

    That has nothing to do with CDA. I'm aware of some bugs in mondrian in some older versions.

    If that doesn't work... use the second format
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  3. #3

    Default

    Alright, I have started using the second one itself. However, I am using Pentaho EE - 4.8 which I suppose has the latest mondrian build. I ran the same in Saiku and it worked fine and thus was confused of why it did not work with CDA. Its pretty was pretty odd and thought would bring to your notice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.