Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Embedding Pentaho Analyzer Report in CTOOLS?

  1. #1
    Join Date
    Jul 2014
    Posts
    15

    Unhappy Embedding Pentaho Analyzer Report in CTOOLS?

    Hey,

    I am trying to embed a Pentaho Analyzer Report in CTOOLS.

    I chose component---->Anaylzer Component--> I put in the row for html object, I give it a name, in the path the below:

    http://pentaho-url:8080/pentaho/api/...3ACompany%20MD

    in the solution box I put in : %3AAnalysis%3APayer%20Mix.xanalyzer/editor

    the full url for this analyzer report is http://pentaho-url:8080/pentaho/api/...nalyzer/editor

    I keep getting an error when I try to load this report. But I know all of my other setting are ok b/c the graph from a graph component I created show up in babyRow1 but in babyrow2 and error screen shows up for the Pentaho Analyzer report....

    what am I doing wrong?

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    your path is wrong. The path should be the path in the solution repository, not the url.

    /home/admin/Analysis/Payer Mix.xanalyzer or wherever you saved it.
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3
    Join Date
    Apr 2017
    Posts
    1

    Default Linking analyzer component

    Hi there is no issue using the Analyzer Component however, the issue I am facing is once its been placed in a dashboard how can you link and pass parameters to the component. For example if I have filters defined in the dashboard how can you configure the analyser component to listen to them? Any help would be appreciated.

  4. #4
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    Set the parameters used by the filters as parameters for the analyzer component. That way, the Analyzer URL will be automatically generated with the parameter values and the component will refresh each time one of those parameters changes.
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  5. #5

    Default

    I am having the same issue, I've set up a simple parameter named PARAM2, and have that parameter passing to an AnalyzerComponent. The response is "Error Processing Component". The Browser console returns:



    cdf-bootstrap-script-includes.js:4638 CDF: TypeError: Cannot read property 'PARAM2' of undefined
    at http://localhost:8080/pentaho/api/re...24b69:6437:882
    at Function.map (http://localhost:8080/pentaho/api/re...424b69:143:147)
    at Object.getOptions (http://localhost:8080/pentaho/api/re...24b69:6437:778)
    at Object.update (http://localhost:8080/pentaho/api/re...424b69:6437:93)
    at Object.<anonymous> (http://localhost:8080/pentaho/api/re...424b69:4658:78)

    Has anyone got this to work? Examples of this working are nonexistent, as far as I can find.

  6. #6
    Join Date
    Nov 2012
    Posts
    24

    Default

    Faced the same issue in Pentaho 7.1.0.0.12.

    Opened the Jira: http://jira.pentaho.com/browse/CDF-980

    Adding the following code in the preExecution will bypass the issue:

    function() {
    this.dateFormats = {};
    }


    Miguel Gaspar
    "Learning Pentaho Ctools"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.