Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Possible issue with queryComponent in CCC2 -b dev?

  1. #1

    Default Possible issue with queryComponent in CCC2 -b dev?

    Hello,

    I have Pentaho 4.8 and have been working on upgrading a load of 3.5.2 CDF files to 4.8 and CCC2. Everything was working OK until I upgraded CCC2 on Monday, since then I've been unable to get queryComponent to run properly. I reverted just the ctools part of my project back to the previous version oc CCC2 I was using and it's all working again, so was wondering if there's an issue with the latest dev code?

    I have a really simple component that returns a session variable of a URL to another piece of software we look after..

    Code:
    var getWmUrl = 
        {
            name: "getWmUrl",
            type: "queryComponent",
            executeAtStart: true,
            resultvar: "wmUrl",
            queryDefinition: MetaLayerQueries.getWmUrlDefinition
    };
    And the definition is
    Code:
    MetaLayerQueries = {
            getWmUrlDefinition : {
                dataAccessId: "getWMURL",
                path: "/" + Dashboards.context.solution + "/cda_data_sources/sessionVariables.cda"
            }
    And the cda file
    Code:
        <DataAccess id="getWMURL" connection="1" type="sql" access="public" cache="true" cacheDuration="3600">
            <Query>
                select ${wmURL} as wm_url
                </Query>
            <Parameters>
                <Parameter name="wmURL" type="String" default="${[session:wmUrlMsvr]}"/>
            </Parameters>
        </DataAccess>
    I've double checked using probe and the session URL is definitely available in the session where queryComponent is not working. There's not much to go on error wise, just these two rows in firebug:-

    Code:
    CDF: Error updating getWmUrl:
    log(m=
    "Error updating getWmUrl:", type=
    "error")script...8e7bda9 (line 4254)
    updateLifecycle()script...8e7bda9 (line 4282)
    
    
    
    ...sed",UNBOUND:"unbound",VIEW:"view"},globalContext:true,escapeParameterValues:tru...script...8e7bda9 (line 4254)
    CDF: InvalidInput log()script...8e7bda9 (line 4254)m = "InvalidInput" type = "exception" updateLifecycle()script...8e7bda9 (line 4282)
    ...sed",UNBOUND:"unbound",VIEW:"view"},globalContext:true,escapeParameterValues:tru...script...8e7bda9 (line 4254
    Is this something I've setup incorrectly using the ctools_installer?

    Many thanks,

    stevens_ns

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    There haven't been any changes to QueryComponent in the last months, so I'm not sure of what might be happening here. Can you run the dashboard with &debug=true in the query string and check firebug. The logs will be more explicit that way.

    thanks!
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3

    Default

    Hello,

    There's still not an awful lot to go on there, here's what &debug gives
    Code:
    CDF: Error updating getWmUrl:
    log()Dashboards.js (line 120)m = 
    "Error updating getWmUrl:"
    type = 
    "error"
    
    
    
    (?)()Dashboards.js (line 654)
    
    
    
    console[type]("CDF: " + m);Dashboards.js (line 120)
    CDF: InvalidInput log()Dashboards.js (line 120)m = "InvalidInput" type = "exception" (?)()Dashboards.js (line 655)
    console[type]("CDF: " + m);Dashboards.js (line 120)
    Many thanks,

    stevens_ns

  4. #4
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    What's the call to that CDA returning? Is it a valid response?
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.