Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Database connections in Enterprise Console vs. User Console?

  1. #1

    Default Database connections in Enterprise Console vs. User Console?

    What is the difference between creating database connections in the Enterprise Console vs. the User Console?

  2. #2

    Default

    Hi rob.emenaker,

    in User Console you cannot create new database connections.
    In User Console you can create, through the Agile BI plugin, OLAP cubes and reporting metadata using database connection that are already available.

    Database connections can only be created in the Enterprise Console.

    Hope this helps!

    Alessandro

  3. #3
    Join Date
    Nov 2009
    Posts
    687

    Default

    Hi AlessandroPD

    You can make a database connection in the User Console. When you go in the menu to File > New > Data Source you can make a new database connection. The database connection wil also appear in the Eterprise Console. I don't think there is any difference

  4. #4
    Join Date
    Jan 2013
    Posts
    101

    Default

    When you make a connection in the user console that is specific to the client and the same configuration must exist on the server or you will receive an error "Report Validation Error".

    If you can create a connection in the Enterprise Console, the benefit is that you can use the server side UI to create reports with your database you have defined. I need this capability for example using MongoDB but have never been able to create on the server side.

  5. #5
    Join Date
    May 2013
    Posts
    27

    Default

    As per my understanding, database connections in the Enterprise Console is connecting database to the admin end and the other is connecting database to the user end. However, I don't know how far this is right.

  6. #6

    Default

    Dear All

    I have the problem about database connection that I have too many database connections without any use in pentaho,I raised the max allowed connections already to 70 but still it goes over.
    Kill 543 root localhost:42199 hibernate Sleep 11 --- ---
    Kill 544 root localhost:42200 hibernate Sleep 11 --- ---
    Kill 545 root localhost:42201 hibernate Sleep 11 --- ---
    This is my context :

    <Context path="/pentaho" docbase="webapps/pentaho/"><Resource name="jdbc/Hibernate" auth="Container" type="javax.sql.DataSource" factory="org.apache.commons.dbcp.BasicDataSourceFactory" maxActive="20" maxIdle="5" maxWait="10000" username="root" password="" driverClassName="com.mysql.jdbc.Driver" url="jdbc:mysql://localhost:3306/hibernate?autoReconnect=true" validationQuery="select 1" maxPoolSize="100" minPoolSize="10" acquireIncrement="5"/><Resource name="jdbc/Quartz" auth="Container" type="javax.sql.DataSource" factory="org.apache.commons.dbcp.BasicDataSourceFactory" maxActive="20" maxIdle="5" maxWait="10000" username="root" password="" driverClassName="com.mysql.jdbc.Driver" url="jdbc:mysql://localhost:3306/quartz?autoReconnect=true" validationQuery="select 1" maxPoolSize="100" minPoolSize="10" acquireIncrement="5"/></Context>

    What should I do to solve this problem,

    thankyou
    Last edited by sacpv04; 05-14-2013 at 04:18 AM. Reason: grammer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.