Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Admin Console: Connection Refused

  1. #1
    Join Date
    Apr 2013
    Posts
    3

    Default Admin Console: Connection Refused (resolved)

    Working with CE 4.8.0...
    BI Platform configured to work on port 80 and against postgres, seems to be working perfectly.

    My Admin Console config.xml file (solution-path and war-path have been edited):
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <console>
      <solution-path>/opt/pentaho/biserver-ce/pentaho-solutions</solution-path>
      <war-path>/opt/pentaho/biserver-ce/tomcat/webapps/pentaho</war-path>
      <platform-username>joe</platform-username>
      <biserver-status-check-period-millis>30000</biserver-status-check-period-mill$
      <homepage-url>http://www.pentaho.com/console_home</homepage-url>
      <homepage-timeout-millis>15000</homepage-timeout-millis>
      <!-- comma separated list of roles (no spaces) -->
      <default-roles>Authenticated</default-roles>
      <default-server-dir>biserver-ce</default-server-dir>
    </console>
    Added postgresql-9.1-902.jdbc4.jar to /opt/pentaho/administration-console/jdbc

    BI Server started, Admin console started

    When accessing the web interface of the admin console, I'm getting a "Connection Refused" popup and this in the trace:
    Code:
    11:40:54,897 INFO  [Version] Hibernate Annotations 3.3.1.GA
    11:40:54,941 INFO  [Environment] Hibernate 3.2.6
    11:40:54,954 INFO  [HttpMethodDirector] I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    11:40:54,955 INFO  [HttpMethodDirector] Retrying request
    11:40:54,955 INFO  [HttpMethodDirector] I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    11:40:54,956 INFO  [HttpMethodDirector] Retrying request
    11:40:54,956 INFO  [HttpMethodDirector] I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    11:40:54,956 INFO  [HttpMethodDirector] Retrying request
    11:40:54,971 INFO  [Environment] hibernate.properties not found
    Is there further config I need to do so that the admin console "knows" the hibernate db has been moved to postgres?
    Last edited by dekova; 04-12-2013 at 03:05 PM.

  2. #2
    Join Date
    Apr 2013
    Posts
    3

    Default

    Resolved:
    I had modified bi server to run on port 80 but hadn't adjusted the fully-qualified-server-url param in web.xml

    setting the value to http://localhost/pentaho/ fixed the issue.

  3. #3
    Join Date
    Feb 2013
    Posts
    9

    Post No admin console when using SSL

    Hi,

    I'm facing the same problem in my development server but after I switched to HTTPS.
    No matter what I put in web.xml fully-qualified-server-url param (basically https://my-server:8443/pentaho/) it gives me the same error: "Connection refused" and it keeps on trying.

    The BI works fine in HTTPS, even when I force the use of it. I do that using web.xml, see below:

    Code:
    <security-constraint>
            <web-resource-collection>
                <web-resource-name>HTTPSOnly</web-resource-name>
                <url-pattern>/*</url-pattern>
            </web-resource-collection>
            <user-data-constraint>
                <transport-guarantee>CONFIDENTIAL</transport-guarantee>
            </user-data-constraint>
        </security-constraint>
    
        <security-constraint>
            <web-resource-collection>
                <web-resource-name>HTTPSOrHTTP</web-resource-name>
                <url-pattern>*.ico</url-pattern>
                <url-pattern>/img/*</url-pattern>
                <url-pattern>/css/*</url-pattern>
            </web-resource-collection>
            <user-data-constraint>
                <transport-guarantee>NONE</transport-guarantee>
            </user-data-constraint>
       </security-constraint>
    
       <security-constraint>
          <display-name>Default JSP Security Constraints</display-name>
          <web-resource-collection>
             <web-resource-name>Portlet Directory</web-resource-name>
             <url-pattern>/jsp/*</url-pattern>
             <http-method>GET</http-method>
             <http-method>POST</http-method>
          </web-resource-collection>
          <auth-constraint>
              <role-name>PENTAHO_ADMIN</role-name>
          </auth-constraint>
          <user-data-constraint>
              <transport-guarantee>NONE</transport-guarantee>
          </user-data-constraint>
       </security-constraint>
    Any advice will be greatly appreciated.
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.