Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Minimum value on y-axis

  1. #1

    Default Minimum value on y-axis

    We have a graph that sometimes gets a value of 50 and another day 10.

    I want the difference in size to show and not that it auto adjust the scale to fit the size of the visible graph.

    I also need to be able to show values higher than 50 when that happens, but in that case I think a auto-scale is allowed.

    I am using Pentaho CDE with CCC graphs.

  2. #2
    Join Date
    Mar 2012
    Posts
    645

    Default

    I think this is what you need:

    orthoAxisFixedMin: 10

    orthoAxisOriginIsZero: false // not sure you need this

    ( for CCCv1 replace: /ortho/y/ )

  3. #3

    Default

    Doesn't seem to work. If I set orthoAxisFixedMin to 5 and I have one value at 1 it will set the baseline to 1 and not show the value in the graph. Any other suggestions?

  4. #4
    Join Date
    Mar 2012
    Posts
    645

    Default

    Hi Erik,

    I'm assuming that you are using CCCv2.

    There is another option that may affect the minimum and maximum values "orthoAxisDomainRoundMode".

    Code:
    orthoAxisFixedMin: 10
    
    orthoAxisOriginIsZero: false,
    
    orthoAxisDomainRoundMode: 'none'
    If domain round mode is 'tick' or 'nice', the fixed min or max might still get rounded to the nearest outer tick.

    If this does not solve the problem, please provide some more information, like a print-screen with the behavior you describe and, if possible, the passed-in options' values (you can get this from the debugger console, if you add the query string parameters "debug=true&debugLevel=10").
    Last edited by duarte.leao; 04-24-2013 at 09:36 AM.

  5. #5

    Default

    Hi

    I tried this now. In the current graph at this current moment I have values up to max ~55. If i set orthoAxisFixedMin: 100 the origin y-scale will start at the same value as I have max value in the graph. Graph is thus empty.

  6. #6
    Join Date
    Mar 2012
    Posts
    645

    Default

    Hi Erik,

    there was a bug that prevented the fixed minimum going above the maximum domain value. I've fixed this in the dev branch.

    If you can use this branch, try it by updating your CTools using the marketplace (choosing the TRUNK-SNAPSHOT versions) or the CTools installer (using the "-b dev" options).
    If you can't, the fix will be available in the next regular release.
    If you can and are already using the DEV branch, you should only need to update CDF and CGG.

    Please let us know if this solved the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.