Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: [ISSUE] JasperReport Execute Error

  1. #1
    Join Date
    Apr 2013
    Posts
    8

    Default [ISSUE] JasperReport Execute Error

    Hi guys!
    I am trying to excute an JasperReport into Pentaho (biserve-ce-4.5.0). I have created the xaction file with Pentaho Design Studio. LIke this:

    Code:
    <?xml version="1.0" encoding="UTF-8"?><action-sequence> 
      <name>Riepilogo Attivita Frontiera</name>
      <title>prova Frontiera</title>
      <version>1</version>
      <logging-level>debug</logging-level>
      <documentation> 
        <author>James Dixon and Barry Klawans</author>  
        <description>%description</description>  
        <icon>jasper-reports-test-2.png</icon>  
        <help/>  
        <result-type>report</result-type> 
      </documentation>
    
    
      <inputs> 
        <output-type type="string"> 
          <default-value>html</default-value>  
          <sources> 
            <request>type</request> 
          </sources> 
        </output-type>  
        <endYear type="string"> 
          <sources> 
            <request>endYear</request> 
          </sources>  
          <default-value>2012</default-value> 
        </endYear>  
        <startYear type="string"> 
          <sources> 
            <request>startYear</request> 
          </sources>  
          <default-value>1999</default-value> 
        </startYear>  
        <endMonth type="string"> 
          <sources> 
            <request>endMonth</request> 
          </sources>  
          <default-value>1</default-value> 
        </endMonth>  
        <startMonth type="string"> 
          <sources> 
            <request>startMonth</request> 
          </sources>  
          <default-value>1</default-value> 
        </startMonth>  
        <officeID type="integer"> 
          <sources> 
            <request>officeID</request> 
          </sources>  
          <default-value>10113</default-value> 
        </officeID>  
        <ufficioEscluso type="integer"> 
          <sources> 
            <request>ufficioEscluso</request> 
          </sources>  
          <default-value>10361</default-value> 
        </ufficioEscluso> 
      </inputs>
    
    
      <outputs/>
    
    
      <resources> 
        <report-definition> 
          <solution-file> 
            <location>RiepilogoAttivitaFrontiera.jrxml</location>  
            <mime-type>text/plain</mime-type> 
          </solution-file> 
        </report-definition> 
      </resources>
      
      <actions> 
        <action-definition> 
          <component-name>JasperReportsComponent</component-name>
          <action-type>report</action-type>
          <action-inputs> 
            <endYear type="string"/>  
            <startYear type="string"/>  
            <endMonth type="string"/>  
            <startMonth type="string"/>  
            <officeID type="integer"/>  
            <ufficioEscluso type="integer"/>  
            <output-type type="string"/> 
          </action-inputs>
          <action-resources> 
            <report-definition type="resource"/> 
          </action-resources>
          <component-definition> 
            <jndi>ORCL_CONN</jndi> 
          </component-definition> 
        </action-definition>
     
      </actions> 
    </action-sequence>
    but when I try to launch the report on Pentaho I get the error reported in the log (attachement).
    Please HELP ME!!!
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.