Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Invalid number format for port number

  1. #1
    Join Date
    May 2013
    Posts
    1

    Exclamation Invalid number format for port number

    Hi.

    I am seeing this message in the log of the kettle process in some of my transformations, but I can't figure where is coming from or why is being launched.
    2013/05/29 14:25:29 - org.pentaho.di.trans.steps.databaselookup.DatabaseLookupMeta@dbde45 - ERROR (version 4.0.1-stable, build 13826 from 2010-08-26 14.18.03 by buildguy) : Error connecting to database: (using class oracle.jdbc.driver.OracleDriver)

    2013/05/29 14:25:29 - org.pentaho.di.trans.steps.databaselookup.DatabaseLookupMeta@dbde45 - ERROR (version 4.0.1-stable, build 13826 from 2010-08-26 14.18.03 by buildguy) : Error de E/S: Invalid number format for port number


    • The port is a parameter passed to the "initial" Job and should be passed to every transformation or job used in the process. I have reviewed (several times) them and I haven't been able to find a discrepancy. In every transformation or job, the same parameter is used.
    • The main job ends sucessfully.


    Any idea what might cause it?.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    The messages are from a Database Lookup step targeting an Oracle database in one of your transformations.
    If you specified the port number as a named parameter of the parent job, make sure you have defined the parameter in each child job and transformation that needs access to this parameter.
    A job can end successfully and still have errors in one or more transformations.
    So long, and thanks for all the fish.

  3. #3

    Default

    Hi Marabu,
    I am also facing the same problem Does it holds true for all the parameters passed in a job? .I have a job with three transformations.I am using all the database connection values used in transformation to be passed as parameters. I have the values such as ${HOST},${PORT} in all the transformations but still I am getting the error when I execute the job through java.
    Please help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.