Hello,
I have a PRD report (.prpt), where i have applied a format like #,##0 for number fields, so that i have the thousand separator ','.
When this report is published to console, i see that comma for large values.
But when the same report is generated via PDI (using the pentaho reporting output) - accessing the prpt from the published location, there is no comma !
Why is that ?


Here are the details of the problem :


  • Number field in prpt file, with formatting applied like $#,#0.00
  • Preview this report in xls, or export to xls from PRD - desired formatting is visible.
  • Publish this same prpt to the Pentaho console and view it there - desired formatting is visible.
  • Use PDI to generate report (pentaho reporting output step) and save it on a local location - desired formatting is NOT visible.
  • Use PDI to generate report and then use Mail step to email the same report as attachment - desired formatting is NOT visible.


PDI version 4.4.1
PRD version 3.9.1-GA.16112

I'm really hoping the solution is as simple as a setting some attribute !


Thanks a lot !