Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Issues when adding a new datasource

  1. #1

    Default Issues when adding a new datasource

    Hey Everyone,

    Really sorry if this is a repost of something, but I could not find much to help me, if there is another thread that would answer this question for me let me know.

    So I have downloaded and setup the bi-server and admin console. All seems to be going well. I was able to install some plugins like Saiku and CDE, CDB, CDC, CDV. So I thought I would add my own database, I followed the instructions on the Help of the Admin console and setup a new database connection
    Name:  dataconnection.jpg
Views: 37
Size:  18.6 KB

    I than tested my connection
    Name:  successfulConnection.jpg
Views: 32
Size:  20.3 KB

    Great! According to the help this is all that needs to be done for me to have access. However, after restarting the server and logging in when I go to create a new adHoc report the available datasources are still the same list I initially did.
    Name:  availableDS.png
Views: 36
Size:  8.7 KB

    So think to myself maybe I am supposed to configure this in the client? So I go to the home page of my dash and click Create New Datasource. I type in the name and select NES1948 (this is the one I added in the admin console, so I am surprised to see it here and not in the available datasources).
    Name:  NewDS.jpg
Views: 30
Size:  25.1 KB

    When I enter next it comes up with a Waiting... Fetching Table information message that just hangs there forever, If I try to manage existing datasources and pull in "Select * from NES1948" I get an Error0009 message. Do you know any reason why this might be happening? Do I need to add a driver somewhere or something? Any help would be appreciated. Thanks!

  2. #2
    Join Date
    Jun 2013
    Posts
    2

    Default

    Had exactly the same problem. This fixed it, I copied the jar file to the following locations:
    ./administration-console/jdbc/mysql-connector-java-5.1.17.jar
    ./biserver-ce/tomcat/lib/mysql-connector-java-5.1.17.jar
    ./biserver-ce/tomcat/webapps/pentaho/WEB-INF/lib/mysql-connector-java-5.1.17.jar

    You should now be able to do selects and table source definitions.

    There is another problem with MySQL that I have not been able to fix, see http://forums.pentaho.com/showthread...le-quote-!-%29

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.