Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Basic use of Carte

  1. #1
    Join Date
    May 2013

    Default Basic use of Carte

    I read a lot, I tried everything.. but I still not able to:

    launch a transformation from browser

    I found the documentation very poor about this.. I mean for a basic user like me..

    Environment: Windows
    PDI 4.4 stable -> directory: C:\Documents and Settings\Administrator\Desktop\data-integration
    Java jre7 -> Environment variable: JAVA_HOME = C:\Programmi\Java\jre7

    I try to explain what I did from the start. I think well..

    I launched spoon.bat
    created a new repository:

    Name:  1.jpg
Views: 217
Size:  32.1 KB

    created a transformation that generate a random number and save it in a file txt on the desktop

    Launching the transformation locally (Transformation2.ktr) , all it's ok..

    After this I launch Carte from cmd

    Carte.bat 8081

    the URL http://localhost:8081/kettle/status/
    give me the correct initial page

    Name:  2.jpg
Views: 245
Size:  34.3 KB

    Now the problems.. how to launch Transformation2.ktr?

    I read that the previous kettle status page just show something previous launched.. How I can launch it?

    I tried this:


    or with a user and password that I don't have..


    but I always get an error:

      <result>ERROR</result>  <message>Errore inatteso durante l&apos;esecuzione della trasformazione: org.pentaho.di.core.exception.KettleException: Unable to get object information for object with id=null    at org.mortbay.thread.QueuedThreadPool$ (    at$ (    at org.mortbay.jetty.HttpConnection.handle (    at org.mortbay.jetty.HttpParser.parseAvailable (    at org.mortbay.jetty.HttpParser.parseNext (    at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete (    at org.mortbay.jetty.HttpConnection.handleRequest (    at org.mortbay.jetty.Server.handle (    at org.mortbay.jetty.handler.HandlerWrapper.handle (    at org.mortbay.jetty.handler.HandlerCollection.handle (    at org.mortbay.jetty.handler.ContextHandlerCollection.handle (    at org.mortbay.jetty.handler.ContextHandler.handle (    at org.mortbay.jetty.servlet.SessionHandler.handle (    at org.mortbay.jetty.servlet.ServletHandler.handle (    at org.mortbay.jetty.servlet.ServletHolder.handle (    at javax.servlet.http.HttpServlet.service (    at javax.servlet.http.HttpServlet.service (    at org.pentaho.di.www.ExecuteTransServlet.doGet (    at org.pentaho.di.www.ExecuteTransServlet.loadTransformation (    at org.pentaho.di.repository.filerep.KettleFileRepository.loadTransformation (    at org.pentaho.di.repository.filerep.KettleFileRepository.getObjectInformation (    at org.pentaho.di.repository.filerep.KettleFileRepository.getObjectInformation(    at org.pentaho.di.repository.filerep.KettleFileRepository.loadTransformation(    at org.pentaho.di.www.ExecuteTransServlet.loadTransformation(    at org.pentaho.di.www.ExecuteTransServlet.doGet(    at javax.servlet.http.HttpServlet.service(    at javax.servlet.http.HttpServlet.service(    at org.mortbay.jetty.servlet.ServletHolder.handle(    at org.mortbay.jetty.servlet.ServletHandler.handle(    at org.mortbay.jetty.servlet.SessionHandler.handle(    at org.mortbay.jetty.handler.ContextHandler.handle(    at org.mortbay.jetty.handler.ContextHandlerCollection.handle(    at org.mortbay.jetty.handler.HandlerCollection.handle(    at org.mortbay.jetty.handler.HandlerWrapper.handle(    at org.mortbay.jetty.Server.handle(    at org.mortbay.jetty.HttpConnection.handleRequest(    at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(    at org.mortbay.jetty.HttpParser.parseNext(    at org.mortbay.jetty.HttpParser.parseAvailable(    at org.mortbay.jetty.HttpConnection.handle(    at$    at org.mortbay.thread.QueuedThreadPool$ by: java.lang.NullPointerException    at org.pentaho.di.repository.filerep.KettleFileRepository.getObjectInformation(    ... 20 more</message>  <id/> </webresult>

    This is my C:\Documents and Settings\Administrator\.kettle\repositories.xml file

    <?xml version="1.0" encoding="UTF-8"?><repositories>
      <repository>    <id>KettleFileRepository</id>
        <description>Repository cartella</description>
        <base_directory>C:\Documents and Settings\Administrator\Desktop\repository</base_directory>
      </repository>  </repositories>
    I tried to put .kettle folder on C:\Documents and Settings\Administrator\Desktop\data-integration
    and setting an environment variable
    KETTLE_HOME = C:\Documents and Settings\Administrator\Desktop\data-integration\.kettle

    but I get always the same result

    I also tried to change transformation passing output to servlet (I don't know what this means)

    Name:  3.jpg
Views: 199
Size:  22.5 KB

    Finally I also tried to create a server slave (I don't know what this means)

    Name:  4.jpg
Views: 200
Size:  23.1 KB

    Final objective is to call the transformation from another pc on the net.. I imagine that I have to trouble with that because I tried to call status page and there are differences if I start Carte with or with
    Last edited by darpao; 06-22-2013 at 06:19 AM.

  2. #2
    Join Date
    May 2013


    This what I get when I try to launch transformation from browser:

    Loading transformation with ID : null

    Name:  5.jpg
Views: 197
Size:  47.3 KB

  3. #3
    Join Date
    May 2013


    I think I solved the problem.

    After the creation of slave server, right click on it - Monitor, to see if it's ok.

    If yes, launching a transformation and executing it remotely, just choose the "prova" remote connection just created.

    If all it's ok (in my case no, because I have problem with transformation), you are able to see the new transformation on status Carte server.

    Maybe could be a good idea integrate Carte documentation with this last step: from creating a slave server to launch the transformation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.