Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: CBF Compiling Errors

  1. #1
    Join Date
    Jun 2013
    Posts
    28

    Default CBF Compiling Errors

    Hi dears,

    I want to develop Pentaho CE with source code.
    So I was decided to use Pentaho Community Build Framework(CBF) and follow as this site.
    http://wiki.pentaho.com/display/COM/...uild+Framework
    Compiling process is nearly ok.
    But I have following errors. I am not sure what are I modified.

    ------
    install-kettle-plugins:
    [unzip] Expanding: D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-build\kettle-plugins\pentaho-big-data-plugin-1.3.0.zip into D:\Java\PentahoWorkspace\cbf-quickstart\target-build\tomcat-pci-test\biserver-ce\pentaho-solutions\system\kettle\plugins

    assemble:

    prep-dev-biserver:
    [xmlvalidate] 1 file(s) have been successfully validated.

    dev-update:
    Duplicated project name in import. Project subfloor defined first in D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-assembly\build-res\subfloor.xml and again in D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-api\build-res\subfloor.xml

    init:

    compile.pre:

    compile.compile:
    [javac] Compiling 165 source files to D:\Java\PentahoWorkspace\cbf-quickstart\target-build\tomcat-pci-test\biserver-ce\tomcat\webapps\pentaho\WEB-INF\classes
    [javac] javac: no source files
    [javac] Usage: javac <options> <source files>
    [javac] use -help for a list of possible options


    BUILD FAILED
    D:\Java\PentahoWorkspace\cbf-quickstart\build.xml:293: The following error occurred while executing this line:
    D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-build\dev_build.xml:157: The following error occurred while executing this line:
    D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-build\dev_build.xml:159: The following error occurred while executing this line:
    D:\Java\PentahoWorkspace\cbf-quickstart\target-build\bi-platform-api\build-res\subfloor.xml:1151: Compile failed; see the compiler error output for details.

    Total time: 8 minutes 59 seconds
    -------

    Please let me know your opinion.

    Regards,
    Ye` Win.

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    Are you using windows ?

    Are you running CBF in cygwin? Directly on the command line ?


    We usually use cygwin when we're in windows.
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3
    Join Date
    Jun 2013
    Posts
    28

    Default

    Quote Originally Posted by pamval View Post
    Are you using windows ?

    Are you running CBF in cygwin? Directly on the command line ?


    We usually use cygwin when we're in windows.
    Thank you for your reply!!
    Yes, I also use cygwin and overcome the problem.
    But some errors still remaining in runtime.
    If would you mind , please refer the link==>http://forums.pentaho.com/showthread.php?136882-Getting-started-with-BA-server-4-8-0-and-CBF-5-1 and let me know your suggestion.
    Thank a lot!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.