Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Cube shows up in Saiku but not Pentaho Analysis

  1. #1

    Cool Cube shows up in Saiku but not Pentaho Analysis

    Hey everyone,

    I want to manually create a cube using a Mondrian.xml file and use the cube for analysis in Saiku and Pentaho Analysis. I have successfully created my cube and store it in the folder <pentahosolutions>/sledgehammer/analysis/MockData.mondrian.xml.

    Name:  MondrianHlep.png
Views: 195
Size:  10.4 KB

    I setup my datasources.xml file to reference this as follows
    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <DataSources>
    <DataSource>
    <DataSourceName>Provider=Mondrian;DataSource=Pentaho</DataSourceName>
    <DataSourceDescription>Pentaho BI Platform Datasources</DataSourceDescription>
    <URL>http://localhost:8080/pentaho/Xmla?userid=joe&amp;password=password</URL>
    <DataSourceInfo>Provider=mondrian</DataSourceInfo>
    <ProviderName>PentahoXMLA</ProviderName>
    <ProviderType>MDP</ProviderType>
    <AuthenticationMode>Unauthenticated</AuthenticationMode>
    <Catalogs>
    <Catalog name="SteelWheels">
    <DataSourceInfo>Provider=mondrian;DataSource=SampleData</DataSourceInfo>
    <Definition>solution:steel-wheels/analysis/steelwheels.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="SampleData">
    <DataSourceInfo>Provider=mondrian;DataSource=SampleData</DataSourceInfo>
    <Definition>solution:steel-wheels/analysis/SampleData.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="MockData">
    <DataSourceInfo>Provider=mondrian;DataSource=MockData</DataSourceInfo>
    <Definition>solution:sledgehammer/analysis/MockData.mondrian.xml</Definition>
    </Catalog>

    </Catalogs>
    </DataSource>
    </DataSources>

    Now I go into Saiku and refresh and my Cube shows up! Great!

    Name:  saiku.png
Views: 200
Size:  19.1 KB


    However, when I try to go open this up in the Pentaho New Analyis the cube doesnt show up.

    Name:  pentacubes.png
Views: 184
Size:  26.9 KB


    I have read a couple posts that say that I should restart the server and it will pick up the cube. But I have tried that and nothing changes. Does any one have any other ideas about this? I have added the new files that have been created to pro_files table as well, dont know if that helps at all, but I am stumped as to why saiku would pick it up but not Pentaho.

    Any and all help would be appreciated.

  2. #2

    Default

    ah! found another post that had answered my question, I needed to refresh the Mondrian Schema Cache. Sorry I hope I didnt waste anyones time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.