Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Olap Selector Component "Error processing component"

  1. #1
    Join Date
    Nov 2011
    Posts
    2

    Exclamation Olap Selector Component "Error processing component"

    Hello,
    I'm trying to use the Olap Selector Component in a dashboard.
    I'm using a stock pentaho (download&run), and I've installed CDE, CDF, CCC and Saiku by using the ctools-installer.sh
    I've a cube called 'Sales', and it works great by using Saiku OLAP tool.


    But when I try to run a dashboard with the olap selector (a plain one, with just the selector), it gives me "Error processing component (Clients)"
    This is the configuration of the component:

    Name:  olapselectorError.jpg
Views: 351
Size:  6.8 KB

    The pentaho.log also shows
    Code:
    ERROR [pt.webdetails.cdf.dd.olap.OlapUtils] Received catalog 'solution:Demo/cube.xml' doesn't appear to be valid
    ERROR [pt.webdetails.cdf.dd.olap.OlapUtils] Failed to get valid connection
    Any suggestion? Am I doing something wrong?

    Thanks!
    Cheers

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    Seems to be a problem with finding the mondrian cube by its definition. Can you open a bug at redmine.webdetails.org so we can track it ?


    thanks
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3
    Join Date
    Nov 2011
    Posts
    2

    Default

    Done! Thank you very much.

    Cheers
    Alberto

  4. #4

    Default

    Hi,

    You have to put the complete Path to the Mondrian Schema, for example

    Mondrian Schema: /steel-wheels/analysis/steelwheels.mondrian.xml

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.