Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: cst problem ! It does't work !

  1. #1
    Join Date
    Aug 2013
    Posts
    1

    Question cst problem ! It does't work !

    Hi, i'm trying to set up a particular StartUp for diferents Roles and User, but it does't work.This is my cstConfig in pentaho-solution/CST/cstConfig.xml
    <?xml version="1.0"?>
    <cstConfig>
    <rule match="USER" pattern="false" value="ruben">

    <tab title="Extractos Bancarios" order="1">
    /pentaho/content/pentaho-cdf-dd/Render?solution=Movimientos+Extracto+Bancarios&path=&file=tablerocuentas.wcdf
    </tab>

    </rule>

    <rule match="ROLE" pattern="false" value="Admin">

    <tab title="Dashboard" order="2">/pentaho/PreviousHome</tab>

    </rule>
    <rule match="DEFAULT">
    <tab title="Tab8">t8</tab>

    <tab title="Tab9">t9</tab>

    </rule>
    </cstConfig>

    And this is my MantleSentting.properties in pentaho-server/webapps/pentaho/WEB-INF/lib/mantle-3.6.0-stable.jar#uzip/org/pentaho/mantle/server

    show-explorer-view-on-startup=true
    show-advanced-features=false
    # startup urls (each displays in its own tab)
    num-startup-urls=1
    startup-url-1=/pentaho/content/pentaho-cdf/RenderXCDF?solution=CST&path=%2F&action=cst.xcdf&template=mantle
    startup-name-1=CST
    startup-url-2=/pentaho/welcome/welcome.html
    startup-name-2=Welcome
    # plugin perspectives
    num-plugin-perspectives=1
    plugin-perspective-url-1=/pentaho/adhoc/waqr.htmlplugin-perspective-name-1=Ad hoc Reporting
    plugin-perspective-url-2=/pentaho/interactive-reporting/index.html
    plugin-perspective-name-2=Interactive Reporting
    # ui customization settings (if menu/toolbar are disabled, the logo panel is disabled automatically)
    show-menu-bar=true
    show-main-toolbar=true
    show-logo-panel=true
    show-theme-switcher=true
    user-console-revision=
    #should the enter key to submit filechooser dialog (save, save as, open) be disabled?
    #turn to false if you need to use the enter key to choose multibyte characters from a dropdown
    submit-on-enter-key=true

    It always show the same. I don't know what's wrong.

    Thanks !
    Last edited by fedebelve; 08-21-2013 at 09:16 AM.

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    what does it show ?
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.