Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: CTools dashboards not rendering in IE8

  1. #1
    Join Date
    Apr 2007
    Posts
    2,009

    Default CTools dashboards not rendering in IE8

    Hi,

    I saw a post from Pedro back in December saying the dashboards should broadly work in IE8.

    However they don't even render at the moment.

    Here is the error:

    SCRIPT5007: The value of the property '$' is null or undefined, not a Function object
    Render, line 1415 character 3

    <script type="text/javascript">
    $( function(){
    //$(".round").corner();

    Pointing to the $(function() { bit there..

    This is easily reproducible in IE10 if you go to dev tools then IE8 compatability mode.

    Curiously the EE dashboards seem to render fine. Could it be some new change?

    Rgds,
    Dan

  2. #2
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    Ah, here is the full error stack. IT seems like jquery doesnt even get going:

    SCRIPT1028: Expected identifier, string or number
    scripts.js, line 6372 character 298
    SCRIPT5009: 'jQuery' is undefined
    jquery.sparkline.js, line 217 character 3
    SCRIPT5009: 'BaseComponent' is undefined
    CDF.js, line 2 character 1
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 8 character 3
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 323 character 1
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 1025 character 1
    SCRIPT5007: The value of the property '$' is null or undefined, not a Function object
    Render, line 1029 character 3
    SCRIPT1028: Expected identifier, string or number
    scripts.js, line 6372 character 298
    SCRIPT5009: 'jQuery' is undefined
    jquery.sparkline.js, line 217 character 3
    SCRIPT5009: 'BaseComponent' is undefined
    CDF.js, line 2 character 1
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 8 character 3
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 323 character 1
    SCRIPT5009: 'Dashboards' is undefined
    Render, line 1025 character 1
    SCRIPT5007: The value of the property '$' is null or undefined, not a Function object
    Render, line 1029 character 3

  3. #3
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    Turns out you have to use dev CDF/CDE and then it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.