Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Problem with Configuration of Database Connection

  1. #1
    Join Date
    Oct 2012
    Posts
    10

    Question Problem with Configuration of Database Connection

    I am working with MSSQL Server 2005 and MSSQL Server 2008 on my latest project, and I have imported Transformations and Jobs from another individual working on this project on another system. Somehow my database configuration now include "${TARGET_SCHEMA}" in the Instance Name of my connections. This is causing me no end of problems.

    I have tried to remove this property from the Instance Name through the Database Connection Panel without success, it just reappears after you accept the changes and close the Database Connection Panel. I then though I would look for it in the .kettle and .pentaho directories, but without any success. I even went as far as searching the disk for "TARGET_SCHEMA" without any success.

    The only way I have found to fix this issue is to completely delete all of the connections and then recreate them every time I do an import into the Repository. I import into the Repository quite often so this is not a very good fix for the problem.

    My question is, where is this property stored and why is it inserting itself into my Database Connection? How do I eradicate it from my connections?

    Regards,
    Steve Johnson

    pdi-ce-4.4.0-stable
    java 1.7.0_25
    Windows XP Pro 2002 SP3

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    You might be confronted with a shared connection.
    You can find them in ${user.home}/.kettle/shared.xml
    There is an option to control import of such connections in the Tools menu.
    So long, and thanks for all the fish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.