Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: How to use c3p0 driver in kettle

  1. #1
    Join Date
    Oct 2013
    Posts
    3

    Question How to use c3p0 driver in kettle

    Hello. I'm using a kettle to make some big transformations with my data which I get from mongoDb and writiing to MySql. I'm using mysql. So i add default mysql connector to kettle. I create mysql connection. In the beginning of my transformation data is read from MongoDb and then some transformations like sort and grouping and thread lookups are made. In the end of transformations there are musql lookup and mysql table ouput. In the server mysql wait_timout is set to 3 minutes, but transformation is longer then 3 minutes and when kettle trying to make mysql lookup connection is already closed. Default mysql connector cant recoonect so I decide to use c3p0. In the pentaho BIserver it's easy to use c3p0. But in kettle it's not obvious.
    I tried to modify data-integration\plugins\spoon\agile-bi\platform\pentaho-solutions\system\hibernate\mysql5.hibernate.cfg.xml and add
    Code:
    <!-- c3p0 connection pooling settings -->
        <property name="connection.provider_class">org.hibernate.connection.C3P0ConnectionProvider</property>
        <property name="hibernate.c3p0.acquire_increment">3</property>
        <property name="hibernate.c3p0.idle_test_period">14400</property>
        <property name="hibernate.c3p0.min_size">5</property>
        <property name="hibernate.c3p0.max_size">75</property>
        <property name="hibernate.c3p0.max_statements">0</property>
        <property name="hibernate.c3p0.timeout">25200</property>
        <property name="hibernate.c3p0.preferredTestQuery">select 1</property>
        <property name="hibernate.c3p0.testConnectionOnCheckout">true</property>  
        <property name="hibernate.c3p0.acquireRetryAttempts">30</property>
        <property name="hibernate.c3p0.acquireIncrement">5</property>
        <property name="hibernate.c3p0.idleConnectionTestPeriod">300</property>
    But when I run a transformation it disregards this config.

    So the question is - How to make a kettle to use c3p0?

    Thank You.

  2. #2
    Join Date
    Oct 2013
    Posts
    3

    Default

    Does anybody can help me? Problem is very actual

  3. #3
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    good question.
    however you can workaround the timeout see here:

    http://wiki.pentaho.com/display/EAI/MySQL

    But i'd also like to know if it's possible to use c3p0 in pdi.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.