Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Pentaho PDI 4.4 is compatible with CDH 4.4.3?

  1. #1

    Default Pentaho PDI 4.4 is compatible with CDH 4.4.3?

    Hi,

    I tried installing PDI 4.4 in Cloudera Virtual Box CDH 4.4.3. I changed the Plugin.properties files to refer cdh4 folder.

    I tried with a sample KTR to copy a file from local to HDFS using "Hadoop Copy Files" component and it is working file.

    But when I try with MapReduce, I am getting different errors every time. First time I got permission issue, then I disabled the checkbox thru Cloudera Manager to allow permission for HDFS. Later I am getting not valid DFS or some kind of error.

    Please let me know whether PDI 4.4 is compatible with CDH 4.4.3.. If not what is the supported version of CDH for pentaho 4.4?

    Appreciate your help..

    regards,
    Rams

  2. #2
    Join Date
    Sep 2012
    Posts
    71

    Default

    The Hadoop configurations available for PDI 4,4 are listed (and often downloadable) here:

    http://wiki.pentaho.com/display/BAD/...ro+and+Version

    Sounds like you're looking for the "cdh42" shim.

  3. #3

    Default

    Quote Originally Posted by mattb_pdi View Post
    The Hadoop configurations available for PDI 4,4 are listed (and often downloadable) here:

    http://wiki.pentaho.com/display/BAD/...ro+and+Version

    Sounds like you're looking for the "cdh42" shim.


    Hi Thanks for your reply... can you please provide the download link for shim cdh42...

  4. #4
    Join Date
    Sep 2012
    Posts
    71

    Default

    It's a bit more complicated than that, as more than just the shim was added in that release. The link above has a link to this download/upgrade page:

    https://support.pentaho.com/entries/...nd-PDI-4-4-1-x

    If you're using the Enterprise Edition of PDI, you should get the latest (4.4.2 or 4.4.3, can't remember) which already has the cdh42 shim. If you're using the Community Edition, you should follow the instructions from the link above to replace your Big Data plugin with 1.3.3.x, which contains the cdh42 shim.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.