Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Hadoop version for PDI 4.4

  1. #1
    Join Date
    Oct 2013
    Posts
    3

    Angry Hadoop version for PDI 4.4

    I tried to use (Hadoop 1.2.1, hadoop -2.2.0) with PDI 4.4 and it did not work. My question is very clear. What Hadoop version works with PDI 4.4? Also I tried to follow the steps in some postings to change the JARS for PDI but it did not work. Please provide me the straight steps to change the Hadoop version for PDI. I think to change the Hadoop version for PDI should be very easy to try it and to make sure that work fine. I need this to advice my company to use Pentaho with big data (if it works fine).

  2. #2
    Join Date
    Oct 2013
    Posts
    3

    Default

    We have to change the plugins one folder for Data_Integration (PDI 4.4) to make PDI works with Hadoop by doing :

    1. Go to “data-integration\plugins\pentaho-big-data-plugin\hadoop-configurations\hadoop-20”
    2. Copy the folder (hadoop-20) to hadoop-121
    3. cp –r hadoop-20 hadoop-121
    4. Delete (commons-codec-<version>.jar & hadoop-core-<version>.jar) from “hadoop-121\lib\client\”
    5. Copy the files (commons-codec-<version>.jar & hadoop-core-<version>.jar) from your Hadoop version to “hadoop-121\lib\client\”
    6. Add the file commons-configuration-<version>.jar from Hadoop version folder to “hadoop-121\lib\client\”
    7. Change plugins.properties [ data-integration /plugins/ pentaho-big-data-plugin/] by pointingto the new flder:
      active.hadoop.configuration=hadoop-121
    8. Start spoon noew “./spoon.sh


    “It worked fine”

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.