Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Run SSH Commands step fails to connect to localhost

  1. #1

    Default Run SSH Commands step fails to connect to localhost

    I would like to run some ssh commands on the local machine where PDI is running, but no matter what I try (localhost, the IP, loopback IP), I cannot get the Run SSH Commands step to connect to the local machine.

    I can use the Run SSH Commands step to connect to remote machines, and can also ssh back to the the local machine.

    What am I missing?

    thanks

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    You should try to connect via command line, before using Kettle.

    If you did, what was the result?
    So long, and thanks for all the fish.

  3. #3

    Default

    When I run ssh localhost (using cygwin), it works fine. Then I tried using ssh-copy-id to set it to not require a password, and PDI ssh localhost started to work! But only when I supplied the password, which had been set correctly all along. Note that it now (after ssh-copy-id) it works with or without the "Use key" option, but before it did not work in either case.

    thanks
    (using: pdi-5.0.1, win-7, cygwin)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.