Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Running Excel Input file in Unix

  1. #1
    Join Date
    Apr 2013
    Posts
    7

    Default Running Excel Input file in Unix

    Hi,
    I am using a transformation where I am loading data directly into the database and the input file is an Excel file. The transformation worked fine when I tried to run the transformation
    on a Windows system. However, I faced an error while running the transformation through Unix.
    The error message says
    ERROR 20-11 10:30:34,427 - Microsoft Excel Input - Error processing row from Excel file [/app/pentaho/pentdv/CAMSFEED/DEV/ART_SFG.xlsx] : org.pentaho.di.core.exception.KettleException:
    java.util.zip.ZipException: invalid entry size

    The error occurs ONLY when excel files are used. It works fine with text and csv files.
    Do we have to change the encoding for Excel files in Unix?

  2. #2
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi,

    as you are trying to read a XLSX, did you set the "Spread sheet type (engine)" accordingly? (http://wiki.pentaho.com/display/EAI/...ooks+%28ODS%29)

    Cheers,

    Tom
    Also known as "_TomS_" on IRC (##pentaho and ##saiku)
    Feeling curious? Visit my blog on http://me-myself-and-it.blogspot.de/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.